Mistyping Password Locks up Octopi

If I mistype the password for Octopi it locks up the whole session. The other thing is that it is quite confusing as to what password it is asking for it shows su root and yet it really needing the sudo password for my user.

I have a different password for my admin root account as that makes more sense. I know the installer wants them both to be the same but I wouldn’t even do that in windows.

Yes, this is a known issue with kdesu, it’s not actually locked up, it’s just a long delay.
We do use exactly the same settings as upstream Manjaro for dbus, pam, etc…
I’ve spent countless hours trying to find what causes this issue with no success.

Ok at least it is a known issue. Antergos KDE doesn’t use Octopi. Pamac works much better but that is just my opinion.

Pamac uses libalpm directly and authenticates via polkit.
Octopi uses pacman in the background and authenticated via su (kdsu)

Pamac also uses appstream data, this is why it displays packages differently.
Pamac breaks them down into their parts, and the actual package name is in parenthesis at the end of the package listings.

Does this mean you may consider switching to palace.

I ended up removing octopi then xterm and everything is working great with palace… Its a great piece of software for me.

We are planning a QT version of Pamac: