mouse cursor theme not working in firefox/chrome

Hey guys,
So here’s my issue, At some point after the first or second reboot the mouse cursor theme just stops working with firefox/chrome and it just resorts back to a default white curor. I have experienced this problem since 13 12 has been released, i have redownloaded the iso and reinstalled it a few times on muiltiple machines and always have the same results eventually. Step by step here is what i do after installing the system. First things i change the default mouse cursor theme by clicking on the gear (krunner) and typing mouse in the box and then click on cursor themes, i then change it to oxygen white, or black sometimes, (already installed) and then run muon and update everything. after that i tested firefox and everything seems fine. Then i upgraded to the lastest kde by running sudo commands to enable backports, then update, then dist uprade, step by step from after that finished i restarted and opened firefox and it starts out as the oxygen cursor and then changes back to the default white cursor, all within 10min of installing the system and upgrading the lastest kde, and thats just it, thats just todays attempt. I’ve reinstalled this thing at least a dozen times by now on at least 5 different laptops and i’ve tried to pinpoint exactly what i do right before i reboot that causes it to happen. This time it was upgrading to kde 4.12.1, but there have been times where i didnt upgrade kde or the kernel and it eventually just stoped working in firefox and chrome and maybe a few others i havent discovered yet but it def works in the begining. This little bug is driving me crazy, I have friends that use netrunner and they tell me they dont have this issue but i have it on 5 laptops. both 32 and 64bit, I even downloaded the iso a few times just to make sure my copy was not flawed, Has anyone else had this issue/? if not try it, change your cursor theme to oxygen white and then reboot, load firefox, wait a few sec and then bam it just back to the default cursor and will switch back to oxqgen once you get to the top bar. Just looking for feedback and to see if anyone else has experienced this problem/?
ha ha after i post it it then shows me possibly related threads, i read where bentalarico posted he was having pretty much the exact same problem, it doesnt seem they ever found a solution though, But at least i know im not the only one, I have netrunner running on an old alienware and i always switch it to this alien cursor theme so thats how i originally noticed the issue, there was no such issue in 13.06 or earlier , i been using since blacklight.

Yeah pretty much this is an issue related to the messy code in Xorg for setting up cursor themes.
The only advice I can give you is place your cursor theme globally in the /usr/share/icons folder (needs root rights)
and try setting the default cursor for the system with
sudo update-alternatives --config x-cursor-theme . For new themes you need first install them to the update-alternative system. See the manpage of update-alternatives (man update-alternatives) for this.

THank you, yes that actually worked. i now have my cursor in firefox again.