Muon not starting; Text missing letters in GTK applications

Hi, I have installed Netrunner 16 64-bit. Both Muon Discover & Update Manager are not starting when I click on the icons. An empty window opens up but nothing is displayed inside it, except for the title bar. Also, GTK applications like Synaptic and Firefox often displays text incorrectly missing some letters, like “F le” for “File”, “P i t” for “Print”, etc. Qt applications like Dolphin and VLC display text correctly. I have attached snapshots of both problems.



I updated through apt-get many times, but these bugs still persist. Please help.

Not sure about Muon, but the font rendering issue is usually caused by wrong compositor settings.

I didn’t change any of the desktop or window settings since installation of the OS. They are at the default settings.

KWin autodetects graphicscards and choose the settings it thinks will fit.
Apparently they don’t for your graphicscard or driver.
So please take a look at the compositor settings in systemsettings.

The muon problem and the screenshot somehow tell me that it might be a dbus problem. Can you somehow reproduce or force this problem with a certain action or does this problem happen randomly ?
Does muon work at all ?
If it isn’t can you test with a new user ? Maybe a config is broken for your user.

  1. I ran Muon Discover and Muon Update Manager from the terminal and found the cause of the problem. My network uses a proxy for Internet connection, so I had already enabled proxy in /etc/environment, KDE System Settings and /etc/apt/apt.conf. However, Muon Discover and Muon Update Manager don’t recognise these settings and are trying to connect to the Internet with no success, like this:
    Surprisingly, Muon Package Manager recognised the proxy settings and worked perfectly. I later connected my computer to a network without a proxy, disabled proxy settings everywhere and then Muon Discover and Muon Update Manager worked. So these two do not work in a proxy-enabled network, but Muon Package Manager works everywhere.

  2. This is the Compositor settings tab. Please could you advise which setting I should change?
    Also since only GTK programs are affected by the “missing letters” problem and Qt programs are not, could it be the fault of GTK settings? This is the GTK settings tab.

What about setting proxy settings in systemsettings?
As far as I know it only needs root rights for the installation and not the muon gui itself.

As for the gtk problem. I am not sure. You could change the compositor OpenGL version to something else and see if it works.
The same goes for the gtk theme settings. See if another theme is working better.

I had already changed the KDE proxy settings to be the same as the environment variables like this:
But Muon Discover and Update Manager do not recognise these settings.

That’s the old kcmshell4 proxy settings from Plasma 4 (KDE SC 4), try this in the terminal and set it up again:

kcmshell5 proxy

kcmshell5 proxy didn’t help. Both programs are still getting stuck. Also, why are the tabs for System Bell, Diagnostics and Input Method in System Settings showing the error “The shared library was not found.”?

Those shouldn’t be there in the first place as they basically are non existent on plasma 5

System bell and diagnostics are no longer part of plasma 5, input method requires kcm-fcitx to be installed.