My Toshiba Satallite L50-B-1N8 would not boot from dvd-rom

Dear Friends I am in utter distress and dismay. I have bought yestarday a Toshiba Satallite L50-B-1N8, and soon I got home I tried to install Linux Netrunner 14, but I couldn’t. It is praticalli impossible to make the dam thing reading from the DVD-rom. I have changed in the Bios the boot order, but NOTHING APPENED!

PLEASE - PLEASE, I don’t wont get stuck with Windows 8, I rather throw in the bin the dam laptop. Can anyone give me the solution please ??? : huh :@

Thank you in advance.


If this is a UEFI laptop with secure boot than you will need to disable secure boot. Please read and follow these instruction on installing Netrunner 14:

Thank you very much for your suggestion. I have disable secure boot, but it didn’t help. I have used a Linux installation DVD from a Linux Magazine that I bought for that very purpose, but still it would not read it. I read the article you suggested, but it is a bit complicated for me. I am almost seventy years old man. I don’t like Windows 8, and that is an under statement. Thank you very much for your help. I will take the laptop to a place hoping that they will be able to solve the problem. It seems like a nightmare to me. Thanks once more; I do love Linux world. Take care of yourself.

Dear Friend,
I was about to take the laptop to a place, when as last resort, I tried on more time to read your suggestion, and I discovered with a great surprise, that the change in the Bios regarding the placing of “CSM Boot” had not taken place. Maybe I didn’t save the changes on exit. The cut the story short, finally I got rid of WINDOWS 8 :wink:

I have risked to get killed by an hoverdose of satisfaction. I AM DRILLED TO BITS!!!


Damn I just bought a Toshiba L50 B 1N8 on ebay because it was cheap. Did you ever get Netrunner set up on it or did I just waste my money?