NAS network sharing/print server issues

I’m having trouble (in some cases) connecting a new Netrunner 14 installlation to a NAS device (Vantec NexStar FX NST610NU-N1). First the good news. I was able to create a network folder in Dolphin using the the “Add Network Folder” in the “Network” link under “Places” with full access to the files (snapshot 1, NAS/Music entry; the Music folder is actually in a network share called “Public” which is supposed to have access by everyone). No username or password was necessary. I used the “Microsoft Windows network drive” selection and the devices IP address in the folder creation dialog to create it. I have full read/write access.

I want to add that folder to my Clementine library but it does not appear in Clementine’s File Menu (and I don’t know if/where it is mounted). If the file is mounted somewhere and I am able to add it to my Clementine library, that would solve most of my problem.

I loaded smb4k to try to create a mount point I could find (I had successfully done this in the past with a Windows Home Server). When I try to access NAS in smb4k, I get stuck in a loop where I get repeatedly asked for a name and password (even though these aren’t supposed to be needed; snapshot 2). I tried using the admin username and password for the device, but the prompt just reappears. I set up an account on the NAS just to create a name and password, but using that name and password just causes the prompt to reappear too. My Windows machines all easily find and use the folder with no username or password prompt, but I can’t get Netrunner to do so.

In addition, the NAS has a print server function. My Windows 7 machines all find and setup the printer (HP Deskjet 9800) no problem and give it the address //NAS/usblp. I’ve tried every configuration I can think of in the Netrunner printer setup dialog without any success.

BTW, the NAS device uses a tiny version of Linux as it’s operating system. I have a hunch this is all about permissions, which I don’t understand at all.

Any help with these issues would be appreciated.

Once you add it to the system using Neiwork Drives it should be automatically mounted under Network in your home directory, just point Clementine at that mount point.

For the printer you need to install hplip and/or hplip-gui for an easy to use printer dialog with more HP Pinter specific features exposed.