Need fast Dolphin

I love Netrunner Rolling OS. I think dolphin’s loading time can be reduced a little bit.File manager is taking more time to open.

Netrunner Rolling is based on Manjaro.

Dolphin’s seems to be taking about the same amount of time on my Manjaro KDE Edition installation as well.

Its blazing fast here. Ok I am running that on an ssd that might explain that I don’t see any delay. If you are using an older harddrive it might explain it being a little bit slower.

Since both of the issues you have posted in both threads sounds to me like a kernel/udev problem I need to ask, have you re-booted your system since your last update?

I’m on Netrunner 14 and I also found Dolphin a bit slow to open compared to Nautilus and others softs that opens instantly.
I have a SSD Samsung 840 and Dolphin is the only softs that is “relatively” slow to start. It has a 1s lag on openning.

I made a little video to show you the lag :

There’s a good chance dolphin5 will be faster compared to dolphin4.
Note that dolphin is also much more powerful than nautilus, it comes with many options enabled in Netrunner.
To make it instant we could also see if we can preload it on start time.

It is preloaded by default already.

Is there any way to check if dolphin is preloaded into RAM on a certain machine?

Normally dolphin is not completely loaded into RAM but only most of its libraries are as they are shared with plasma or other kdelibs.
I would not recommend using the preload trick we use for firefox as this might introduce other problems. Instead I would rather check out if in startkde (or a local user startup script) improves the loading time.
My first tests did not show any difference between completely hidden but open dolphin window or using LD_PRELOAD or loading dolphin from the default setup.
Might be that the ssd is doing a fine job here for me.
I will perform some tests on a normal harddrive later this day to see if any of this options help.

Leszek with your SSD do you notice a 1s lag when you open Dolphin ?
I have this 1s lag with my SSD each time I open Dolphin and it will be great if we can reduce it, if it’s possible.
It is not essential, but it’s nice when programs starts instantaneously.

Have you tried disabling some of the extra services that Netrunner has running in dolphin by default?

I just tried to disable all services and it’s the same.

Yeah dolphin takes about 1s to open up. I never saw this as slow though as it is instantanous to me.
I am not sure if its somewhere in the code. But it could be a hardcoded value. But you need to take a look in the sourcecode to get to know more about it and maybe find the culprit.

I hope you don’t ask me to look into the code because I don’t have this skill :wink:
Anyway if it’s not easily fixable it’s not really important but it would have been nice.

Finding a sleep method isn’t really hard :slight_smile:
But anyways if I find time I will take a look at it. But if I don’t find a sleep than it might be a technical limitation.
I don’t see any big filemanager loading faster btw. Some might load the user interface faster but then start loading the icons for files and folders which makes them effectively slower. But it might give the impression of faster loading as they show the user interface a little bit quicker.