need help bumblebee installation

hi

im new to netruner an also new to linux
i have no idea at all how to install an program. that was why i never wanted linux because you always need to do a lot of things in the terminal. with netrunner i dont need to install anything because it already has eerything i need. except bumblebee. i looked it up on their site but all those codes and things you need to do is like magic to me.
can anyone help me?

First of all. Bumblebee is not packaged in Ubuntu yet as it is supposedly not yet stable enough. Also notice you need the nvidia drivers already be installed by the driver manager (KDE menu -> Settings).
So to install bumblebee it you need to add an software archive which contains bumblebee packages. (bumblebee itself and all it dependencies). Todo this do:

  1. Goto KDE menu -> settings -> software sources. Click on ppa and click on Add a new ppa
    Copy and paste the following into the textfield:

Click on ok and read the information provided by the bumbleebee software repository. It gives you a link were you can find help if something went wrong. Hit Ok if you are ready.

  1. Click on Update the cache in the top right corner of the software sources window. Wait until its finished then you may close the software sources window.

  2. Goto KDE menu -> system -> Muon Package Manager . Search for bumblebee click the package which is called bumblebee and in the bottom right (above the description of the package that shows up) click on Mark for: Installation. It will ask you if you want to mark additional packages which bumblebee depends on and you hit ok.

  3. Do the same for the packages virtualgl & linux-headers-generic.

  4. Click on Apply Changes button in the top left of the window. (next to Preview Changes)

The next step is to simply reboot the machine.
You can test if bumblebee is really active by running the following tests in a terminal (don’t worry just copy and paste these commands and hit enter)

glxspheres

Wait for a few seconds to see the framerate.
Then run it again explicetely telling it to use bumblebee

optirun glxspheres

You should notice the difference in framerate.

I hope that helps.
Btw. installing normal software is easy as pie if you use the Muon Discover application in the KDE menu -> system.

i tried it (yes i know i waited almost a month :P)
but i have 2 problems
the first is that i have no desktop effects anymore
and the second is with the first command to check if bumblebee is working i get the following error:

christian@christian-Aspire-V3-571G:~$ glxspheres Polygons in scene: 62464 Xlib: extension "GLX" missing on display ":0". ERROR (593): Could not obtain RGB visual with requested properties

and by the way i installed the driver not from the driver manager because it only showed my wireless driver. i installed it with a program called additional drivers. and the driver i used was called NVIDIA binary Xorg driver, kernel module and VDPAU libary and after the installation the name changed to “nvidia_313_updates” maybe i used the wrong one? (there are 4 nvidia drivers to choose from[/code])

i just tried the second command to check if bumblebee was working and it came up with this error:

christian@christian-Aspire-V3-571G:~$ optirun glxspheres
[ 568.036183] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[ 568.036258] [ERROR]Aborting because fallback start is disabled.
[hr]

i managed to fix it :slight_smile:
in the bumblebee settings it said “driver=” i set it to “driver=nvidia” and now everything is working!
the only problem i have (the same i had with optimus) is that it does not start when i play minecraft. is there a command to make the discrete card run with minecraft?