Netflix

Hi, I had installed Netflix Desktop on Netrunner-OS 12.12.1 using wine and it ran fine.

But now in the newly released Netrunner, after installing the same way I did in 12.12.1, and trying to start Netflix, it prompts me with I need to install true type fonts and asks if I want to do so and I select ok and enter the root password. It then comes back with a prompt that says I did not accept the terms and installation of true type fonts and then I click ok and it goes away and nothing else happens.

What has changed in this OS that would make the Netflix program not install properly?

I mean, I like the newest release for the most part, but if I can’t get Netflix to run, I will be forced to use a different distro.
Not that I want to…

Please help!

Try this:

sudo apt-add-repository ppa:ehoover/compholio
sudo apt-get update
sudo apt-get install --reinstall ttf-mscorefonts-installer (use TAB key to go to “OK” and “Enter” to accept EULA)
sudo apt-get install netflix-desktop

Ok… this installed the desktop and I got as far as the black screen before the movie loads and no video ever comes up, yet the sound plays. If I click any where, then Silverlight crashes.

EDIT:
I tried uninstalling netflix and re-installing and now when I select a movie, the whole desktop closes but the sound of the movie starts.

Is there a way to re-install silverlight?

ANOTHER EDIT:
I found a way to re-install silverlight from this site:
http://how-to.wikia.com/wiki/How_to_watch_Netflix_(Watch_Instantly)_in_Linux
But Silverlight fails to install everytime I tried un-installing and re-installing (3 times).

Hmm, thats really a sad story with Silverlight and Netflix…try here:
http://ubuntuforums.org/showthread.php?t=2134848

I also heard Netflix will dirch Silverlight for good in the near future!

This did not work for me.

I’m glad Netflix will drop Silverlight, but sure hope they make it
compatible with Linux!

But I want to get this working Now! :s

Really strange how it worked fine in 12.12.1 and not in this release.

EDIT: As soon as it starts to load the movie the screen goes black,
but no spinning blue dots -and when I move the cursor to the very
top of the screen, Silverlight crashes everytime.

ANOTHER EDIT: Well, for now, I’m going back to 12.12.1 .

I can’t live without Netflix seeing is I own no tv. I got rid of my tv in
2003 and don’t miss that crap-box one bit!

12.12.1 runs Netflix. So until they give up Silverlight… I will try to run
12 as long as I can. I know I had issues with that one, but I’ll give it
another shot.

Well… Netflix is doing the SAME thing in 12.12.1 now!! What the HECK??

I guess I will just go back to Zorin. I actually have Zorin on my other PC
and it works.

See ya!

Perhaps Netflix changed something in a newer software version or something got mixed up with your configuration. Have you tried completely uninstalling it and wiping the configuration ?
See this as reference: http://ubuntuforums.org/showthread.php?t=2134722&p=12618918#post12618918

Ultimate Powers:
Netflix changes and breaks stuff, so here is what I would try:

sudo apt-get install --reinstall ttf-mscorefonts-installer
rm -Rf ~/.wine-browser

Then netflix should reconfigure itself with silverlight and hopefully run.
If not, I’d love to know how Zorin could do the trick to get it running?

Yes I did! If you would have read the entire thread, you would have had the answer to your question. And NO… Netflix didn’t change anything in this regard because I just got done installing Zorin on my main computer and then Netflix and had not ONE ioda of a problem the very first time!

I’m sorry, but I have already installed Zorin and have a small hard drive
so I don’t want to have two OS’s on this PC.

But maybe you should download Zorin 7 and work with it and see for yourself.
I’m serious when I say that installation of Netflix on Zorin was extremely simple!
I simply used the terminal to enter this code:
sudo apt-add-repository ppa:ehoover/compholio
sudo apt-get update && sudo apt-get install netflix-desktop
Then once that was completed, I rebooted the PC and once up, I started Netflix.
Then it started installing the necessary components and I just clicked OK on all.
When that finished, I booted Netflix and immediately was brought to the log-in
screen and I have to say, everything responded smoothly and quickly.

In Netrunner, everything I did, there was a slow “hurry up and wait” type of
response. Like over-burdened resource hog. I even went in and un-checked
the BLUR effect as I had to do in 12.12 for things to work better. But no change
came about in 13.06 .

I feel Netrunner still needs a bit of work, but I do like the OS and would prefer to
use it once it gets better. But for now, Zorin 7 simply Works for me.

This is exactly how it went on my netbook with the tt-fonts installed, it runs netflix exactly like you describe at full speed with fx/transparency on.
I wonder why it didn’t turn out to work on yours. :frowning:

Anyway, good luck with Zorin. :slight_smile:

Hi. I’m having the exact same problem–to a T. Just to let you know, I also have on my computer Linux Mint 15 Cinnamon and Voyager 13.04. On both, everything works normally, as it did in the previous Netrunner. I tried everything outlined in this thread to no avail. I hope you can provide a solution at some point, because Netrunner is my favorite for KDE. Many thanks for the beautiful distro.

Hollandhook:
What happens after you do this:

sudo apt-get install --reinstall ttf-mscorefonts-installer
rm -Rf ~/.wine-browser

Okay, Starbuck. I just did it again.

sudo apt-get install --reinstall ttf-mscorefonts-installer
rm -Rf ~/.wine-browser

This is the sequence that follows:

1-configuration update

2-local installation

3-Netflix Desktop comes up

4-My Netflix Home appears correctly after login

5-Select movie

6-Black screen with cursor comes up and sound plays

7-Bottom left message “transferring data from connection netflix.net

8-Screen stays black; sound keeps playing; and then

9-Silverlight plugin crashes

So, no change at all.

Thanks.

Can you look in /etc/X11/xorg.conf
Code:
Section “Extensions”
Option “Composite” “Disable”
EndSection

If “Disable”, set it to “Enable”.

“bash: /etc/X11/xorg.conf: No such file or directory”

Then please create this file with the content described and try switching between Disable and Enable

Thank you. I would gladly do that. Do I do it in Terminal or file manager? What do I do exactly?

If you know how to use vi or nano you can do it in the terminal (which is recommend as graphical tools could mess around) with

sudo vi /etc/X11/xorg.conf 

Otherwise you can also use kdesudo kwrite /etc/X11/xorg.conf.

Then just paste

and save.

After this reboot or restart Xorg.

I used the kdesudo kwrite option and it worked. Yay!

Thank you both for your help. Happy dance.