Netrunner 15 Hangs on login screen.

Last night I was using my laptop on battery power and forgot to plug in the power supply before we went ount to eat. Needless to say, when I returned from the restaurant, the laptop was powered off. After pluging it in, I tried turning it back on and it boots up to the login screen and allows me to enter my password. When I press enter after entering my password, it hangs and does not take me to my desktop. i am still able to move the mouse pointer, but if I click on the power or restart buttons, nothing happens either. The dots that denote the characters of my password remain in the password field, and clicking in the password field does not put the cursor focus in the field. I waited a long time, thinking maybe it was just doing some sort of checkdisk type activity without indicating so, but the hard drive activity light was not blinking. I tried powering off and back on and cannot get any farther than the login screen. It’s like it’s in a loop or something.

is there some kind of startup repair that I can perform to fix this problem? Or is there a way to boot in a safe-mode in order to see where it is hanging. Any help would be greatly appreciated.


Asus U56E Laptop.
Intel I5.
6GB Ram.
600GB Hard Drive.

You should have a failsafe boot menu option. Or you can just simply switch to a tty and try login in there by pressing for example ctrl+alt+f2 to go to tty2.
After login in there take a look at /var/log/sddm.log the log of the display manager (graphical login tool)
vi is a non graphical texteditor that allows you to see the contents of that file.
The best would be if you could boot from a live usb stick and save that file aswell as the hidden .xsession-errors file in your users home directory and upload it here or put it on a nopaste service.

The filesystem checks are usually performed before the Display Manager is started on mounting the partitions basically.