Netrunner 17.06: No GUI after Installation

Hi guys

I’m not a complete newbie to unix systems but I dont have any command line experience.

I used Netrunner OS 17.06 64bit and installed it on an USB drive. It only starts when I use the failsafe start option. After installing it on my hard drive it won’t boot into a GUI. I just get a command line prompt and when I want to start it from HDD I dont have a choice to start it via failsafe.

I just tried things like startx or init 5 or xinit etc but nothing worked. It seems the X-server isn’t running at all because it couldnt find any displays (that was one of the few details that came back from the shell). I dont really know what this means. Is it an unsupported GPU (AMD R9 280X) or is there something wrong with the config of the desktop environment?

The shell starts blinking/flashing when I try startx and such. Maybe it tries to start a GUI and fails all the time? I just press ctrl+c to make it stop because it’s very annoying. And somehow my keyboard input became invisible. I can write and start commands but I couldnt see what I actually typed.

I’m not really sure how to tackle this problem. Any suggestions? Any other information you need to solve this?

On the bootloader Grub menu edit the menu by pressing e then add to the linux line the boot parameter nomodeset hit Ctrl+X to boot.
This should get you going.
If that works for you you can add this parameter to /etc/default/grub to the GRUB_CMDLINE_LINUX_DEFAULT
You need root rights to edit this file.
To finally update the grub boot loader after changing the configuration execute sudo update-grub in a command line.

Hope that works for you.


thanks for the fast help.

Unfortunately the end result ist quite the same.

I get the error message:
[drm:radeon_init [radeon]]ERROR No UMS support in radeon module!
snd_hda_intel 0000:00:03.0:HSW/BDW HD_audio HDMI/DP requires binding with gfx driver
[drm:radeon_init [radeon]]ERROR No UMS support in radeon module!

I googled a bit and maybe thats interesting:

I have an ATI/AMD R9 280X in an Intel-PC with integrated Intel Board GPU which I never use.

I tried startx and init 5 but then the shell just blicks a few times (trying to get an GUI up?). I looked into /var/log/xorg.0.log as the error message from startx recommends and I can only see the detection of Intel HD Graphics and nothing about my Radeon GPU.
The summary of that log is “no devices detected” and “no screens found”.

I also tried xforcevesa just for fun and the xorg-log ends up in /home/user/ and is empty :confused: