Back to Netrunner | Back to Blue Systems

Netrunner 21.01 No irq handler

Hi, I have been using Netrunner on my laptop for a few months and I really like it I want to switch from Win11 to Netrunner on my main PC but im getting this error im using the same USB I used to install on my laptop.
Also i tried the failsafe boot and it didint change anything.
My specs
GPU: 6800XT
CPU:3900X
RAM 64GB DDR4
Motherboard: X470-F

Unfortunately your hardware is currently not supported out of the box.
It is strange though that failsafe is not booting up as it should run just fine with generic drivers.
What you can try out if your system is booting via legacy boot is hitting TAB key and adding one of these options to see which one works for you.
If you are booting via UEFI hit the e key and add to the linux line after “quiet splash”

iommu=off
iommu=soft
iommu=noforce

If you are unsure if its UEFI or BIOS/CSM you can just hit tab and see if it works and shows you a prompt or hit e and see if you get an editor with a linux line. :slight_smile:

Only try one of those at a time to see which one makes your system boot.
This will allow you to install the system hopefully and after install we need to make the working solution permanent.

Ok so I updated BIOS (UEFI) the vector error no longer appears now its a solid black screen, I let it sit there for 20 mins and nothing happened, I proceeded to try what you suggest and no change at all. Is there an ETA on when my hardware will have support if none of these fixes works? I have tried a few distros and I really like this one.

This is what happens when I use failsafe mode

You tried hitting enter again to see if it triggers something?

Otherwise you need to wait and try again with Netrunner 22.

Just tried it and nothing, my keyboard and mouse also turn off when I try and boot.

Is there an ETA on version 22 and is this 100% that my hardware will be supported?
Im pretty nee to linux I have used it on 2 laptops now due to it being light and snappy on low end hardware but i haven’t dug into to much.

edit!: SOMETHING NEW! Had some errors above Was to busy typing above to get a picture of that

What should I type here?

Hey thats good news. So it is booting up but not in the graphical environment just text environment.
You can try to type in startx to see how far it goes. My prediction is that it will fail because your graphicscard might be not supported out of the box.
But let’s see maybe startx gives you something.

Sorry for slow reply

This is what happened when I tried Startx.

But yeah is there any planned release for Netrunner 22?

If you can also get the contents of /var/log/Xorg.0.log that could possibly help.

Im booting from live USB where do I find that in the folders? Im on Windows 11 if it matters I looked and I dont see that file directory

You can find the file after trying the startx on the live media.

From what I can see it seems your graphics card is not supported. It complains about framebuffer that usually is an indicator for missing graphic drivers or not compatible ones.

You can get an output of the /var/log/Xorg.0.log file by entering
cat /var/log/Xorg.0.log
It will show you the output of that file (scroll through probably) and show you the last lines of that file. You can post a shot of those here. Hopefully it will show a meaningful error that can help.


Here ya go

That shows. That it cannot use your graphics card. It did not detect it and even the fallback vesa one is not working so it tries framebuffer as graphics driver which fails.
You really need to wait for Netrunner 22 and hope your graphicscard will be supported.

So basically im fucked, I see. I guess il use netrunner on my craptop and just wait for SteamOS 3.0 to release or try Kubuntu thanks for the help.