Netrunner-Arch comments

Firstly, I must express my thanks for even considering using Manjaro as a base distribution. I’ve always been extremely impressed by the polish of Netrunner, and my main reservation was the use of the Ubuntu base system. With the rolling release model and the Manjaro tools I expect great things to come.

After downloading the ISO and loading it in a VM, I have some comments and suggestions.

[]It seems to me that the ISO should still be considered beta. While its fully functional, there are some branding issues, and a few other bugs that need to be sorted out before it should be considered production quality, and that should be stated on the download page.
]In the KDE Control Center (System Settings) under Social Accounts->Web Accounts, the module is missing a library. Specifically, however the versions installed are .so.7 and .so.0.8.0
[]In the KDE Control Center under Account Details, the user information, the Name field is “manjaro” and cannot be changed. If the field is modified and apply is clicked, KCM freezes. This bug also exists in Manjaro-KDE.
]There are some minor branding issues on the LiveCD. The hostname, user and password are still “manjaro”. “Manjaro Settings Manager” and “Install Manjaro” in the menu. Small things really, but branding is important.
[]Netrunner-Arch contains GRUB Customizer, which is fine, however since there is a very nice KCM GRUB2 editor, I highly recommend it as a replacement. Website, AUR Package
]Firefox-KDE is installed by default, which is good. The KWallet extension for Firefox would provide even further integration with the system. This is a bit of a preference, and I’m not sure that it should be enabled by default or simply left to the user to decide. There also seems to be an issue with the Mozilla JIT debugger and this plugin, so it may be best to wait until that bug is resolved before inclusion. Website, AUR Package

Keep up the awesome work.

Hello vengefulsquadron and thank you for your feedback!
We will try to completely debrand the ISO naturally, but in case of the left-overs they seem more deeply baked into the Manjaro ISO and not so easy to change, though we will get it all fixed for the next snapshot.
So despite some minor flaws, the first snapshot is quite ready and useable, and with providing the additional packages from the Standard release via the [blueshell] repo, we think it’s already a different experience than the Manjaro base one. As for the bugs, they should be gone in the 64bit snapshot.

I help Starbuck and his team to rebrand their work. Some Manjaro branding, like the kernel tag is hardcoded and not so easy to change. Everything else can be done by forking my sources.

First, I am very glad to see Netrunner utilizing an Arch/Manjaro approach to the base, as I’ve been wanting something different than the Ubuntu base. So far, I’m very happy with how stable it seems to be. I second what most people are saying in having a GUI software center similar to Muon/Ubuntu Software Center. Also, I’m wondering how to get more widgets…I wanted the picture frame widget that worked so well with my previous Netrunner 13.12 - I had two on my desktop-one showing a single picture, and the other I had set as a slideshow…when I go to download more widgets, I can’t seem to find it anywhere…is there something missing? Any help would be much appreciated. Again, so far, this seems pretty rock solid, so I’m extremely pleased.

Is this what your looking for?

sudo pacman -S kdeplasma-addons-applets-frame

I would like to thank you for all all your hard work. I like very much the fact that you made a rolling release based on manjaro.

As far as bugs are concerned i came across the ones that are mentioned above . Also octopi was giving me the tmp is full error because swap wasn’t mounted and had to edit fstab . Again in octopi there is the “This linux distro seems to be incompatible…”

My laptop is a 32bit with 4gigs of ram . I installed the one from the arch repositories which isn’t that hard to do but i would like to ask nonetheless if you are planning in offering a pae-kernel?

Themes and wallpapers are amazing ,it is snappy , love the homerun and homerun-kicker menus and font rendering. Looks great so far :slight_smile:

Hi Narya and thanks for your feedback!
Can you give us more details why no swap was mounted? Did you erase the full disk or select a partition manually during install?

I manually installed because i wanted to create different partition for home , i also created a swap at that point.

Swap shouldn’t be mounted but turned on with swapon, this only needs to be run once… As far as a PAE kernel, that would be up to the netrunner dev’s. Now with that said, installing a PAE Kernel is easy to do since this is manjaro based, just add the manjaro LTS ck1(BFS)+BFQ repository, more info here:

For swap i just did what arch wiki said activated swap and edited /etc/fstab with " /swapfile none swap defaults 0 0 " as it says. For the pae kernel added the repository because with 3.10 hdmi doesn’t work for me.

Also for bluetooth i had to install it from octopi and activate it and webaccounts after today’s update works like a charm .

Excuse any mistakes , English is not my native language :blush:

Yup! Thanks very much!

Another comment Octopi is shipping by default clearloocks as its QT widget style, please make it use Oxygen

Hello, I found out about the rolling release from Spatry cup of Linux Youtube channel. I love this Distro! The only thing I can seem to get to work is Conky, everything I tried gives an error of some sort, I must be missing something when I select items from the yaourt terminal. I also tried it from Octopi and got errors. Since there are 55 items showing up in the terminal, it is easy to miss something. Can you please give me a list of all the items I should pick to get a basic Conky showing up on my desktop. Thanks.

I guess you just install the conky package.

Try this:

sudo pacman -S base-devel

now you should not get those errors from the AUR.

Thanks so much, yes that fixed all the errors!

Your very welcome brother, I’m just glad I could be of some help.

oh whoa… my reservations were also using a Debian system (64 bit). I’ve been running Arch for about 3 years and now Manjaro XFCE4 is on my lower spec systems. Once Rolling gets a 64 bit ISO i will jump to it :slight_smile:

Quick Question. I’m running Enigma 13.12 64 bit on this machine currently. I don’t have a seperate Home or Boot Directory, my HDD is encrypted as well, Is there going to be a problem just Installing Rolling without redoing my partitions and/or formating? i have a lot of files that i dont wanta lose in my HOME directory.

I would recommend doing an backup.