Home

Netrunner Color Theme


#1

How can the color theme be changed to allow Fill-in Blocks to be seen.
The Black Background with almost Black Text is impossible to be seen clearly.
Screenshot_20190117_080443


#2

You can change the color scheme in systemsettings.
This should help.
However where do you see this issue. In which application?
Also have you changed any of the default theming settings like setting a new widget theme?


#3

I tried changing to each of the loaded Theme options and they all did the same thing. I have now gone back to the default theme. One place I see it is on Moneydance.


#4

Have you tried changing Plasma Themes or color-schemes? As the issue lies within the color-scheme as it seems. There are light color schemes that should work much better. The application you are using seems to be a proprietary one. It could be a bug there aswell.
Any problems with other applications that we ship by default?


#5

Isn’t Moneydance a proprietary application that is heavily programmed in java?
At least it was last time I used it.
Have you tried playing with your JVM (java) settings?


#6

I need some hand holding on this. How can I change the Plasma Themes and/or color-schemes? I have worked with Kvantum man and none seem to help.

Moneydance in Windows has a White box window with black text. Also Moneydance worked well in Mint 18.
Also I have seen the same problem with a help box but I failed to make note of what program I was running.


#7

I would not know where to begin with Java.
I will say Moneydance worked well in Mint 18.


#8

To change the color scheme click on “Plasma Tweaks” in systemsettings.
image

And then choose color. Here you can choose from the list.
For example you can use a light theme like Carbon:

Further more we also offer a whole Look and Feel package you can access also under Plasma Tweaks in systemsettings.
If you choose Netrunner Desktop it offers a more light of a theme. Make sure to tick “Use Desktop Layout from Theme”.

If after all of this your app still occurs in dark and unreadable text then maybe it is using the GTK Theme.
To change this you can also under Plasma Tweaks choose the Gnome Application Style (GTK).
I would recommend to choose the Breeze Theme here for GTK2 & 3 and to untick Prefer Dark GTK3 Theme.

Don’t forget to hit apply and restart your application after making this changes.
Hope that helps.


#9

You might find this useful:

or newer:
https://wiki.manjaro.org/index.php?title=Set_all_Java_apps_to_use_GTK%2B_font_%26_theme_settings


#10

Followed your directions.
Color did not help.
However the GTK (Breeze) & untick Prefer Dark completely took care of the problem.
Also Firefox now has a more standard look and is easier to work with.

Thanks A Ton!

I might suggest GTK (Breeze) and untick “Prefer Dark” for the default setting in a future update/release.


#11

Hi jdbhere and thanks for the tip.
Can you let us know which website you saw that “dark on black” password field?


#12

I think it was the mentioned Moneydance application which is an Java Application. They have a plugin to follow GTK Theming. Though Java App Theming in general is an issue as far as I remember. (Its been years I actually used an Java Desktop App)


#13

It actually happens the same to me with some web pages in firefox/waterfox. I’m using the blackbird gtk2/3 theme with the “prefer dark theme” checkbox ticked. I can’t post screenshot right now, but you can try these two: www.ecosia.org (dark background onthe input field) and context.reverso.net (totally screwed up). I believe it might be some ff bug, like falling back to system colors if the webpage doesn’t provide any rule. Annoying nonetheless.


#14

Try inspect element in Firefox, you’ll see where it selects the colors for each element in the style sheets.
Plus, you’ll notice quite a bit of java code.

BTW, many web browsers and java apps are notoriously bad when it comes systems that are using dark themes, especially GTK apps like Firefox and Epiphany (Gnome Web).


#15

Indeed, it’s a ff bug which has been hunting it for 17 years now apparently. Just lol. Should be fixed in the next release, but given I’m on waterfox I’ll just switch to vivaldi for the time being.


#16

Yes, I know.
That’s why I only use Firefox when I absolutely have to.
Falkon is my default browser these days.


#17

You can force set the GTK Theme for input fields in Firefox.
Just set
pref("widget.content.gtk-theme-override", "Breeze");
in prefs.js

This is set by default in our firefox in Netrunner 19.01 and should work.


#18

In case anyone is wondering, you can use this hack: https://www.youtube.com/watch?v=2a7rgRsO6q4


#19

Yes, that is an old hack.
I use that hack on my Enlightenment based system for Firefox, as well others just like it for other gtk applications like epiphany, etc…

The issue is that it has to be modified and applied directly to each individual application.
Whereas leszek’s hack is a one time add, but only works under Plasma.

What would be nice would be a more global, desktop independent hack.
I just wish that the theme designers, and programmers, would to take these kinds of issues into consideration when creating their themes, and,or theme engines.