netrunner freezes completly...


since about 2 weeks I observe the following scenario:

i have opened several programs (libreoffice, thunderbird, okular, chromium). That’s my usual enviroment for my work. After a while the machine complety freezes and the only thing i can do is pushing the power-button to restart the machine.

For testing I have installed manjaro and everything is working perfect, so i assume it’s no hardware-problem.

How can I analyze the problem? And more important, how can I solve the problem?

(My “feeling” says the source of this problem is thunderbird … )

netrunner 17.10
kernel 4.14.0-0.bpo.2-amd64
Plasma 5.11.2



Anything in the logs?
journalctl will help here.

Is it completely frozen or only the graphical user interface?
Can you switch to a tty? Are the magic sysreq-keys working?

Hi thanxs for your answer.

[color=#333333]journalctl shows me only the actuals infos. When the system is frozen I can’t enter “[color=#333333]journalctl”. Everything is frozen, no tty, no gui.[/color][/color]

[color=#333333][color=#333333]Next time the system is frozen I will try the sysreq-keys. (hopefully i will remember them … :slight_smile: )[/color][/color]



My system seldom freezes since I switched to the Chrome browser.
Thunderbird has no issues for me (yet). If you do have issues, try turning off the add-ons to test.
Also, try not running 1 of the programs you listed to help narrow it down.

Ok, thanks,

it’s difficult to turn off programs from my list because that’s my working enviroment. In thunderbird I have only one add-on active. What I can do, is to switch from chromium to chrome.

I have been using maui a very long time on this notebook and never experienced such problems. Then the message came that maui is no longer developed and i switched to netrunner and, to be honest, i regret this decision almost every day.

But, what I’m missing is an answer how to work with “journalctl” to analyze the problem.


now, i tried to use the magic-sysrq-keys on my thinkpad t530 without any success …



[size=small][font=Ubuntu, Arial,]When the system freezes, switch to the console if possible (you wrote, you’re not able to): [/font][/size][color=#242729][size=x-small][font=Ubuntu, Arial,]CTRL[/font][/size][/color][size=small][font=Ubuntu, Arial,] + [/font][/size][color=#242729][size=x-small][font=Ubuntu, Arial,]ALT[/font][/size][/color][size=small][font=Ubuntu, Arial,] + [/font][/size][color=#242729][size=x-small][font=Ubuntu, Arial,]F1[/font][/size][/color]

The SysRq wikipedia page has more information on the various keys and what they do.

Command to check Magic key Sysrq status: cat /proc/sys/kernel/sysrq
[size=small][font=Monaco, Consolas, Courier, monospace]by default you should see 438 [/font][/size]

Perhaps the (Alt+SysRq)+R+E+I+S+U+B commands will not work with the default restriction. If so, then the kernel.sysrq=1 would be required.

Provided the kernel itself isn’t hung & SysRq is enabled without restrictions, follow the instructions within the SysRq wiki to reboot the OS if all other safer ways fail to work. Although not a solution to what’s causing the freezing, it’s better than forcing a power down, until this is solved.

Note: Each of the keys after Alt+SysRq is a command ie: (Alt+SysRq)+R+E+I+S+U+B is executed immediately when pressed. So, a small period of time should be given to each command so that their action can be carried out properly e.g. hold the R key for 1-2 seconds, before moving on to E. If the sequence doesn’t work at first, then increase the time period between each sequence key press and try again.

A quick search found this;

Seems, Netrunner’s focus is on the Manjaro based rolling release.
Unfortunately, my Lenovo laptops operate better with Debian based distros and the smoothest rolling distro was this one. However, the Netrunner backports repo is seemingly no longer maintained/updated.
I tried pure Debian Testing, and KDE was sluggish. The Netrunner tweaks make KDE & the OS quicker.

On one of my laptops, I downgraded qt based packages and dependencies, and use only Debian repos.
That laptop has been running better and updates without issues. Not a procedure I care to do again nor recommend.

Maybe someone can share how the Debian Testing distro is tweaked in Netrunner for a better KDE & system experience? Then I would clean install Debian Testing & tweak it.

So that would mean the kernel froze which is bad as you most probably won’t find anything in the logs then.

Can you try out another kernel maybe? Which kernel do you have running?

There is some planning done already to provide fixes for backports.
There is a plan to provide more upstream synced updates in the future.

As a result of your advice I’m using the [color=#333333][size=small]kernel 4.14.0-0.bpo.2-amd64 in the moment. I can try another kernel. [/size][/color]



Stop regretting and switch to Manjaro!

Sorry, but your reply is not very polite! I’m mentioning Manjaro only because sometimes it’s easier to test the hardware of a machine with an other OS.
I really want to stay with the apt - universe. Meanwhile since 15 years …


I was not implying any impoliteness, simply expressing my summarized view of what you stated.

If my laptop ran better using another OS I would & will change. After all, Linux is all about choice!
I too prefer the apt - universe, but would gladly use an Arch based distro if my laptop operated better with it. However, as posted in #8, it doesn’t. But I did find a solution for another laptop, as I noted in that post.

Hopefully, you’ll find or be provided a solution to your frosty issue. Best of luck…