Netrunner Rolling 2016.1 and Windows 10 Dual Boot

I am receiving the error below when I attempt to install the rolling release on a Lenovo Z70-80 -

[code]Boost.Python error in job “bootloader”.
<class ‘subprocess.CalledProcessError’>
Command ‘grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Netrunner_Rolling --force’ returned non-zero exit status 1
File “/usr/lib/calamares/modules/bootloader/”, line 244, in run

File “/usr/lib/calamares/modules/bootloader/”, line 232, in prepare_bootloader
install_grub(efi_directory, fw_type)

File “/usr/lib/calamares/modules/bootloader/”, line 182, in install_grub

File “”, line 2, in [/code]

Along with the 5 partitions that were on the machine I carved out swap, /boot/efi, /, and /home. The live boot runs beautifully, and the installer seems to be running well until around 51% when this error pops up.

I tried both the free and non-free boots, and had the same result.

I poked around and saw some other people asking about this issue with Manjaro dual-boots, but I didn’t find a solution.
It sounds like in at least one case other distros were working for one of the posters, so I’m going to try Netrunner 17 and see how it goes, but I prefer the rolling release, so I would love to hear any ideas.


Did you get one of the models with the 1tb + 8 gb hybrid drive (sshd)?

Note: The Lenovo support site for this model doesn’t have Linux listed in the OS support menu.

I did, but it does seem to work well with live spins.

I think I got it figured out, netrunner 17 installed smoothly, and I saw a post mentioning ubuntu detects the ESP automatically and realized I should have been mounting the ESP to /boot/efi instead of creating a second troublesome boot partition. The installer went smoothly and I am rebooting now.

Thanks for the response!

Cool Avatar Ambassador Londo Mollari
Have all 5 seasons and did a week marathon watching them about 3 months ago.

The you clearly have good taste, and I am in good company!

Yep wouldn’t been faboolust without Mollari & G’Kar with Vir in the mix.
Made the show for me. Of course loved the evil Bester from Psy-cops.

Well at least I’m not alone in my love for Babylon 5.

In fact can’t sleep yet only 10:30pm here. And it was sitting there in my stacks.
So Yep! Season 1 Disc 1 Let’s us Begin Again! :slight_smile:

So let’s get moving and dust off those DVD’s and get Babylon 5 playing tonight around the Global Linux Community! :slight_smile:

My next binge viewing will have to wait, as I have been having way too much fun getting this beautiful OS set up.

It’s always nice to see people gathered with one common interest discover they have totally unrelated common interests!

Whaaat? What Do you mean Babylon 5 OS runs Linux Right? :s

Yep don’t have cable or even local tv channels. Just a DVD player with a usb port.

Just Binge watched Stargate SG-1 all 10 seasons last 2 weeks. And started Stargate Atlantis but will
mix with Babylon 5. Have so many TV series on DVD’s can keep commercial free viewing going watching while also on the computer.

Have them all DS9,STOS,Next-gen,Voyager,X-files,Twilght Zone,Outer Limits Dr. Who Original and modern versions.
Firefly,Game of Thrones,Rome,Spartacus series. Sanctuary,Eureka,Warehouse 13,

Old series - Addam’s Family,The Munsters,The Time Machine,Voyage to the Bottom of the sea,Batman orig series.
N.C.I.S , CSI all versions,Law & Order and C.I., and other newer series

So never run out of media as have over 3,000 movies and 1,000 Music CD’s that I have been collecting last 30 years or so. :smiley:

I have a few of those same series as well. X-files and B5 top my favorites list, though.

How should I do install it alongside Windows? Is it just a question of mounting Windows boot partition as boot?

The Calamares installer will set this up for you, just select alongside windows.

But when I select my ssd the option to install alongside vanishes. I’ve even freed some space beforehand (print attached)

From the picture there is a 100 meg fat32 partition, this would indicate that Windows was installed in UEFI mode.
The picture also indicates that you are trying to install Netrunner under Legacy (BIOS) mode.
All operating system need to be installed using the same method (UEFI or BIOS) for that feature to work correctly.
You will need to boot the live media in UEFI mode.

Yay, that was it! Thanks! :smiley: Installing Netrunner right now. My computer wouldn’t run the flashdrive in uefi mode, no matter how much I fiddled with the system, so I had to burn a dvd. Apparently, with uefi boot secure, Microsoft wanted to make sure that the life of dualbooters would be a world of pain.