Netrunner Home

Netrunner-settings-sddm: /etc/sddm.conf exists in filesystem


#1

Now I got this. Any hints of what I should do?

pacman -Su 
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (7) firefox-i18n-en-us-66.0.3-0  firefox-i18n-sv-se-66.0.3-0 firefox-kde-opensuse-66.0.3-1
netrunner-settings-autostart-2019.04-2 netrunner-settings-firefox-2019.04-4 netrunner-settings-sddm-2019.04-1 xdg-desktop-portal-kde-5.15.3-1

Total Installed Size: 182.58 MiB
Net Upgrade Size: 0.42 MiB

:: Proceed with installation? [Y/n] 
(7/7) checking keys in keyring [######################################] 100%
(7/7) checking package integrity [######################################] 100%
(7/7) loading package files [######################################] 100%
(7/7) checking for file conflicts [######################################] 100%
error: failed to commit transaction (conflicting files)
netrunner-settings-sddm: /etc/sddm.conf exists in filesystem (owned by sddm-classic)
Errors occurred, no packages were upgraded.

#2

We don’t ship sddm-classic, please switch back to sddm.
To make a long story short, upstream SDDM no longer requires, or ships this file by default.
The sddm.conf file is considered to be legacy, and although we still ship this file for now, the /etc/sddm.conf.d/ directory is the correct location for local config files going forward.

$ man sddm

https://wiki.archlinux.org/index.php/SDDM


#3

Thank you, I replaced classic with default and the update went fine. Not sure why I got classic in the first place.


#4

You probably switch to classic when upstream sddm was causing black screens on boot.
But it is what it is, I’m just glad your problem is solved. Now back to relaxing on my weekend.