back to Netrunner | back to Blue Systems

netrunner-system update 1.1.5?


#1

Surprisingly there was a package update in Netrunner 17. Today I received an update of the package netrunner-system.

This is what apt/dpkg told me:

Vorbereitung zum Entpacken von .../netrunner-system_1.1.5_all.deb ... »Umleitung von /etc/pulse/default.pa zu /etc/pulse/default.pa.orig durch netrunner-system« wird beibehalten »Umleitung von /etc/grub.d/10_linux zu /usr/share/netrunner/grub_10_linux.orig durch netrunner-system« wird beibehalten Entpacken von netrunner-system (1.1.5) über (1.1.4) ... postrm called with unknown argument `upgrade' dpkg: Warnung: Unterprozess altes post-removal-Skript gab den Fehlerwert 1 zurück dpkg: stattdessen wird Skript aus dem neuen Paket probiert ... dpkg: ... sieht so aus, als hätte das geklappt.

“Seems as if that did work”? What did work? What was removed?
Is it a preparation for the update script?


#2

Yes a quickfix for the upgrade script as there was a typo in the postrm script of that package.