Back to Netrunner | Back to Blue Systems

New install initial update errors

I just made a new install of 21.01 – XOXO and then ran “sudo apt update -y && sudo apt full-upgrade” as per the instruction on the download page. There were just too many errors to contemplate fixing without some sort of guide since this must now be a standard occurrence as this distro approaches end of life for how the repos were originally configured.

Otherwise how close is either an updated ISO for 21.01 with correctly configured repos or the new release?

Please tell us or attach an error log.

Thanks. I’d already replaced the original system from a backup but I’ll reinstall Netrunner again and post the update errors.

The was the result.

The machine is a Dell Vostro with i310100 and 8G ram. There is a fixed 1TB HDD and a Samsung nvme0n1 onto which the single system was installed using the default options. The default repos shown were.


I then ran ‘sudo apt update -y && sudo apt full-upgrade -y’ and this was the result of that.
Then I ran Synaptic with this result.
Then I ran the update manager which downloaded the packages but hung on applying changes stating 180 packages would be removed and 402 installed. It required manual intervention to define the key map and then again to allow restarting the services during upgrade. This it began and then locked completely ‘unpacking git’. The only option was a hard shutdown. After rebooting Synaptic would not launch. This was the result of a terminal update.

I see. The issue lies in the Microsoft Skype repository that has an issue with its signature key. I think this is a screw up from Microsoft. If you don’t use the Skype Client or don’t want to use the Skype repository you can disable the http://repo.skype.com/deb/ software source. This should get rid of the error message and upgrading should run fine.
To do so open the software sources in synaptic like you did in Screenshot1 and disable it by pressing the correspondent checkbox.
Do the same for the security debian repository if necessary (this one should be working still but maybe the address changed)

Many thanks for your help. I followed the above and got two more errors although I ignored these because it stated ‘Buster to Bullseye’ and I don’t want anything from the Bullseye repos. I then updated the packages it did provide ignoring these errors. Is there anything else I need to do/change to get a fully updated system?

These warnings can be ignored or acknowledged via apt full-upgrade in terminal only. For some reason Debian decided to make it only acceptable via apt in a terminal.
If you accept those via terminal it should work and after upgrade the warning should go away aswell.

Thanks again. Is all good now.