Back to Netrunner | Back to Blue Systems

New ISOs

Hi All

Is a new ISO due to be released? If not, is there a ‘testing’ ISO that I could download for a new install, rather than download all of the updates since July?

Until the sddm / systemd 235 / kernel modules issues are resolved upstream, I’m not sure an ISO right now would be wise. Especially, since none of my systems have been effected by either of these issues thus far. These issues seem to be random and/or only effect a some users, some have intel, some amd or nvidia, some have changed themes others have not, one single common thread has yet to be found other than the versions of these packages. However, there are two different issues at work here. One is before sddm even loads, the other is after the user logs in and sddm hands off to Kwin.

I know what you mean - I’ve had to install the SDDM-Classic package for it to work - otherwise I get the black screen and no desktop.

Your lucky, there has been at least one report of sddm-classic having the freeze after login issue.
https://forum.manjaro.org/t/kde-hangs-after-login-with-sddm-classic-stable-update-2017-10-26/33563

Just to be sure. The SDDM hanging or slow to load Plasma Desktop appears no matter if the virtualbox guest utils are installed or not?
We solved an issue regarding SDDM hangs when loading plasma in Netrunner as Virtualbox Guest Utils had a notify-send command which causes the very slow loading of the desktop.

This is not a slow loading issue, it’s a complete freeze, and only one of the issues effecting sddm 0.16.0 in Manjaro ATM.
https://forum.manjaro.org/search?q=sddm_boot

From SDDM github:
1: https://github.com/sddm/sddm/issues/905
2: https://github.com/sddm/sddm/issues/906
3: https://github.com/sddm/sddm/issues/903
4: https://github.com/sddm/sddm/issues/915
5: https://github.com/sddm/sddm/issues/891

I went ahead and posted a suggestion on the Manjaro forums to try removing vb guest utils package. I’m not sure why this would effect installs to bare metal, but anything is worth a try at this point. Unfortunately, I’m still not able to reproduce this issue on any of my systems.

Update: After a reply in the Manjaro forums, and a review of our ISO build process, we do not install the KERNEL-virtualbox-guest-modules or virtualbox-guest-utils unless virtualbox is detected during the mhwd process. We do however install KERNEL-virtualbox-host-modules if virtualbox is not detected (running) during the mhwd process. However, what is installed by default in both cases is virtualbox and virtualbox-guest-iso (needed by Linux guest sessions).

I’ve tried to do a new install from a live USB stick and I get a message about waiting for Plymouth and can’t get any further - any idea how to get around this? I can’t even get into the live environment.

Ignore my last reply - I have found out what went wrong. It turns out the live media was corrupted and when I used etcher to ‘burn’ to the USB pen instead of Opensuse Imagewriter, it worked fine. I tried it 3 times with the same ISO file and the same USB pen and both times I used OpenSuse Imagewriter, it failed. It worked perfectly with Etcher though. Strange I know but I am going to use Etcher for writing USB pens from now on.

a situation, I went through many, many times myself, let me tell you. dang … one of those gazillion fails … what was it … hard to remember

That’s interesting, especially since we didn’t ship Netrunner Rolling 2017.07 with plymouth…
Are you sure you didn’t download an old Netrunner Rolling ISO, or one of the Netrunner Debian Editions (1706, core, arm, etc.)?