New release version 23

So Netrunner OS 23 “Vaporwave” was released a couple of days ago (Sourceforge) with no announcement I could find and the only info about it on a foreign language site. The official site still has links to the outdated versions. Problem is with KDE 5.20.5 it’s already out of date unless the system will support an upgrade to 5.25 as per the likes of Kubuntu, Tuxedo etc. Hopefully a ‘Core’ version will also follow which for my needs might be the better option.

Hi,
the release of the Netrunner 23 ISO was indeed published yesterday with the announcement following today.
Since Netrunner is based on Debian Stable, 5.20.x is the latest version on Debian. If a more recent version is needed, you are right that KDE Neon or an Arch-based distro might be better suited, or enabling SID repositories might be used (of course with some risk of making the system possibly unstable).

Thanks for responding. Just one further comment, or question really. Since it appears Leszek is no longer with Blue Systems how if at all will this affect the future development and maintenance of Netrunner and will there be a Core version release?

Development is continued normal, we will focus on the desktop version though, as “Core” wasn’t really updated for some time now even while Leszek was still on board.

Many thanks for the updated info. :slightly_smiling_face:

I went ahead and installed the new release onto my Dell Vostro and the whole process went without issue including the update. A few items I needed to install as extras were Evolution which I much prefer to Thunderbird, KTorrent (another preference), Kpat, Qt 5 xmllistmodel QML module (for the weather widget charts) and gdebi to install Google Chrome, GIS Weather, Etcher and the MX version of Conky Manager. Again, all of this went with zero issues and all of these additions launched and ran without errors… Then I customized the themes using Netrunner Indigo and the default included Oxygen app style, window decorations and icons. Additional items such as the Relax Plasma theme and Nordic Darker KDE color theme again all installed and ran without issue. The very last item on my list was to install some additional plasmoids at which point the plasma shell shut down with a segmentation fault. This is where it ended for me as this is my work PC so I’ve had to reinstall the previous Devuan image. I can provide more info you might need but only if it can be obtained from a live session.

Out of interest from a new live session the desktop still crashed when I clicked to add widgets with nothing else added or altered.

In order to fix the issue with the crash a back-trace is required so the KDE developers can see where in the software stack the crash occurred. See this KDE Wiki Page for a guide on how to produce the information.

Unless I’m missing something the official site hasn’t been updated so there’s no way to check the sha for the downloaded ISO. I did however have the same result with both the direct download and via the torrent file on three completely different sets of hardware. This being the case I’m not sure why it has to be up to us as end users to research and report anything since the issue appears to be with Netrunner’s implementation of KDE since the same version works perfectly well across a whole range of other distros.

Maybe it’s a cache issue? With sha, you mean the sha256 on the Download page?

I think you were right. Previously despite reloading the page I was still seeing only the details for 21.01 XOXO. Now I can see 23 Vaporwave and the sha matches with my downloaded file. The issue with seg faults when clicking to ‘add widgets’ persists however and I’ve tried the same ISO on two more different systems today.

We are looking into the crash issue when trying to add widgets. We’ll update as soon as we can.

Thanks for looking at it.

Is that only happening in LIVE mode? Can you add widgets from the DASH menu “Widgets” tab?

No. It also happens with a fully installed system, not just the live session. Not sure about the DASH menu - will need to setup another session to find out but certainly right-clicking on either the desktop or the panel to ‘add widgets’ results in the same crash.

Update: Can confirm that no matter which method is used to ‘add widgets’ a blank panel appears momentarily on the left side and then disappears. Sometimes the desktop is left intact with a crash notification in the panel, sometimes it results in a black screen.