Netrunner Home

New Rolling User -- Disable firefox autostart


#1

Hi, just installed NRR and got everything updated and running great. Just got a fews issues. How do you disable firefox from autostarting? There seems to be a script for that. When I click on the “status and notification” tray icon there is firefox listed. Please help.

-Chente


#2

Take a look at systemsettings autostart settings.


#3

Remove the netrunner-settings-autostart package.
sudo pacman -R netrunner-settings-autostart


#4

@AJSlye @leszek what is the netrunner-setting-autostart package exactly? What is is autostarting? If I delete it what other packages and setting am I deleting?


#5

It only contains the autostart files for Firefox and imwheel, the later is no longer needed since Plasma 5.15.x.
Needless to say it’s safe to remove this package.


#6

@AJSlye @leszek Removing netrunner setting autostart also enables the usb mouse extra back and forth button – FYI – awesome


#7

Cool, that’s awesome.