New update ruined netrunner

Ok, in console I enter my password, enter sudo apt-get upgrade and I get the following

Reading package lists… Done
Building Dependency Tree… Done
Reading State Information… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded
and that where I’m stuck as I cant get past this and cant login

Thank you

Can you try “sudo apt-get dist-upgrade”?

OK, I tried that and I have the same… after entering password entered sudo apt-get dist-upgrade and…

Reading package lists… Done
Building dependency… Done
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

Still cant log in on start screen.

Try installing kscreen

–>sudo apt-get install kscreen

If kscreen doesn’t solve it, please check ~/.xsession-errors. And if there’s nothing relevant in there, switch to unity-greeter to see if it works.

If you want to give unity-greeter a try, I would recommend that :

sudo apt-get --no-install-recommends install unity-greeter


How about
sudo apt-get -f install
and then
sudo apt-get install plasma-desktop
sudo apt-get install netrunner-desktop ?

Try installing kscreen. If it doesn’t work… and only if it doesn’t work, well… try installing this :

This is the next default netrunner package, I mean for the next release. Currently under development. Don’t worry, it’s harmful to use it on a dryland-te release.

You’ll have some message during installation but nothing to worry about. i tried myself in a fresh dryland-te-12.12.1 installation.

Hi, thanks for your suggestion, unfortunately this also did not work.after entering in the above, I got the following…

'The following packages were automatically installed and are no longer required: plasma-active-data-share-like-connect-data.
Use apt-get autoremove to remove them:
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

Wavespot has suggested Try installing kscreen or new default package

Will try this and see what happens…Thank you

Hello again, I’ve tried to install all the above and still no joy…following packages will be installed…do you want to proceed (Y/N)
I select y, and get error 'could not resolve

Still Ive got one part of my partition working (windows 7),…7_all.deb invalid link

thank you

Hi all,
stumbled upon this conversation because I have what appears to be a similar or same issue.
I’m a noob when it comes to KDE and let’s say just a user of Linux in general with more experience in Windows.
I liked the look of Netrunner so thought I would try to use it as a primary OS (don’t like unity, tried some others but Netrunner looked/felt great via the live cd).
So about 1 week ago, I partioned my HD and installed netrunner-12.12.1-amd64.iso
This all went great up till I tried to apply all patches since that release.

This is where it all went horribly wrong.
After patching, reboot the system and get to the login screen ok.
Type in my password after which I get nothing i.e. the login option disappears but nothing else visibly happens.

Also noticed that the KDE plasma option on the screen below the password entry textbox was missing when the login option came up at boot.
Tried almost all of the options suggested to jasonleeg and got the same responses i.e.
Reading package lists… Done
Building dependency… Done
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded
This was true for all installs except kscreen which had to add a couple of extra packages but which made no difference. System suggested using autoremove which I used, also no impact.
In the end after trying everything I proved that if I installed Xubuntu-desktop that I could login with that and Xfce but no KDE plasma or Netrunner.
I also tried to use wavespot’s file (missing as pointed out above so I chose 6 instead of 7 but either I didn’t know how to use the correct apt-get coomand combo to use it or there is something seriously wrong with the file.
It seemed to go into a infinite loop with stuff scrolling down the screen but no actual change to the system.

Finally I resinstalled netrunner from scratch and I only updated security patches. All good.
But when I added the application and system patches it all went to hell again - which you guys probably knew would be the case but as I said - I’m a noob. It was worth it as an experiment.
And I tried to read the ~/.xsession-errors file but as a noob, I couldn’t really find the root cause. There are a lots of issues in the log and I can guess where it all goes bad but cannot see the bit that jumps out and says “this is the bit that is broken”.

Thank you very much for any suggestions or assistance.
At the moment, it’s either wait for a fix to the upgrade package or rebuild the system again and not apply any system patches which is where I guess the problem is coming in.
I can rebuild the system once more and collect a fresh log if that helps, since I would like to progress the issue.

Cheers - Ben

Fixed the link in my original message.

If you have a resolution error, that’s another issue then.

1- Check your sources file (you wrote launcherpad, instead of launchpad).
2- Then check your /etc/resolv.conf file, it should contains something like nameserver
3- Your network should be up and running : try ping to figure it out.

Hi there, thanks for your advice, don’t think I have resolution issue but as I’m quite new I’m not sure how to check this.
Also how do i check /ect.resolv.conf file? and how does this help with login ?
I really liked netrunner and have 75% of my hard drive allocated to it but for me now its unusable as I cant log in. Maybe its time to jump ship and find another distro and come back to Netrunner when the new version is available in june and this problem has been solved.

Thank you

I had the same problems and I tryed all sugestions presented here, then i decided to reinstall instead of to install with the following commands:

sudo apt-get install --reinstall -y netrunner-desktop
sudo apt-get install --reinstall -y kde-plasma-desktop

Boot and… SOLVED! :slight_smile:

Since my partition wasn’t working properly anyway, I decided to give Mint KDE a try since that’s well liked.
But after giving that a shot, I decided I didn’t like the limitations of Mint.

So, for the 3rd time I gave Netrunner a try thinking a solution may be found.
After installed Netrunner I tried the update again via Muon.
I applied the Security Updates category only 1st.
Then I probably made a mistake. I forgot to restart and updated only the applications that didn’t have a dependency on system updates i.e. un-select system updates which only left me with a few applications.
I applied those updates and then restarted the system.

I got a White screen (no text, nothing) - very broken. I was able to Alt-Ctrl-F1 to a terminal so not completely broken.
So I tried:
sudo apt-get update
sudo apt-get dist-upgrade ----- (lots got updated here)
sudo apt-get -f install ---- (no updates)
and reboot.
It worked this time (3rd attempt at installing and updating to latest).

My verdict, either another update came out to fix the problem (less likely) or Muon has a serious issue (my guess).
I am guessing if I upgraded from scratch again and only used apt-get, it would be fine.

I guess Sidon’s answer is the best but I didn’t see that last night
Cheers all.

Well thanks any way but I tried to fix with these suggestions and had no luck on any of my computers. Well 2 out of 3 any way. The second one I even waited a couple of weeks and thought maybe things were fixed by then. Nope another one bites the dust. The third one I’m not updating until I’m ready to take the time to install another system on there when the update fails again. Too bad too cause I was really liking Netrunner till then. But gave me the chance to check out Mint 14 for a while. Maybe by the time Netrunner 13 comes out things will be working better, hope so. Still it was fun working with it while it lasted.:blush: :blush: