New update ruined netrunner

i just updated netrunner and it did update a lot of things but after the update no restart icon came up so i restarted normally. Then when it was booted up the window manager dissappeared and the themeing got screwed up help :frowning:

Get to a terminal and type:

sudo apt-get -f install

After this completes, reboot.

The problem is the update didn’t complete properly.

The latest update has also ruined my desk top to
Applcations run in small windows.
No maximize or minimize buttons.
Menus in Thunderbird not working.
Terminal does not work anymore.

Think its its time to move to SolusOS.
This is the second time updates have trashed my Netrunner.

Just hope all my mail is still intact.

Well it seems, that kubuntu backports ppa is enabled in Netrunner 12.12.1, and this is why muon is installing KDE 4.10. Is it intentional? If not it should be fixed asap, because in Netrunner 12.12 everything is ok

mine netrunner crashed too :frowning:
I had to install XFCE to get to the desktop.

sudo apt-get update returns - W: Failed to fetch Unable to find expected entry ‘universe/binary-i386/Packages’ in Release file (Wrong sources.list entry or malformed file)

sudo apt-get -f install gives - 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Login screen - I have only XFCE as session, no KDE or Netrunner desktop option

sudo dpkg-reconfigure lightdm does not add anything, I have only XFCE as option

sudo aptitude --full-resolver - could not give me also any solution

I like my KDE Netrunner, how to get it back!?

thanks man that worked now i can use netrunner again properly :slight_smile:

SolusOS is no better than NetRunner and in fact, for me, it was way worse.
They have their own share of issues. But you were given a solution for now
which is, open your terminal window, enter this line without the quotes:
“sudo apt-get -f install”
Then it will ask for your admin password. Enter it and when it asks for Y or
N, simply type Y, hit enter and let it roll! Then once done, re-boot and you
will be good to go!

Don’t pup out and run off to another distro! That is like being at the grocery
store and hopping from line to line, thinking you will get through faster and
ya never do!

But it’s your choice. See ya~

Ok! Got it fixed so sticking with Netrunner. :slight_smile:

finally I have my KDE up and running
had to
sudo apt-get install plasma-desktop

don’t know why it was now available after the update :frowning:

Humble apologies for this, the KDE SC 4.10 update we made had a file which was moved without the needed conflicts so some upgrades will have got confused and not completed.

It can be fixed from konsole by running:
sudo apt-get update
sudo apt-get -f install
sudo apt-get install netrunner-desktop

sorry again for any breakage caused.

Jonathan Riddell

Great! I’m sure in time, this will be a top choice distro!

I was running Netrunner 4.2. I did the upgrade script to bring it up to the latest version.
That worked okay. But I was wondering why I was not getting any notifications that there were updates for the past several days. So I went into Muon Update and found that there were lots of updates available. So I updated my system, rebooted and voila: Nothing. No menu, no anything. Just a black screen. No access to terminal either. My only option was to do a fresh install. Great. Good thing I backed up all my files to a USB drive.

What went wrong ?

Probably the grub menu was messed up, so you could have live booted and tried to rescue it:

One problem I found with the upgrade script is that it doesn’t upgrade your PPA software sources; they’re still attached to the Kubuntu Precise versions, rather than the Quantal versions. This caused a huge dependency problem with the KDE 4.10 update from backports.

I fixed it by removing all PPAs labeled precise and then re-adding them, and then doing the update.

Hope this helps!

Today I’ve updated my system to KDE 4.10.2. on my notebook, and the system crashed totally :huh: . It is a problem with intel graphic card. On my second computer with nvidia card there is no problem at all. Any help how to fix it?

Hi there, I also have problem when I upgraded. I’m stuck at login screen, enter my password and redirected to login screen again. Tried Ctrl + Alt + F1 to get into terminal and entered sudo apt-get update, which works fine and upgrades then sudo apt-get upgrade which doesn’t work. 0 upgraded, 0 newly installed, 0 to remove and 0 not displayed. I’ve been using Netrunner for about 3 months and have been very happy with this distro until the upgrade. Has anyone any suggestions?
Thank in advance

Hi jasonleeg,
Have you upgraded the distribution or softwarepackages? If you only upgraded the softwarepackages try a manual upgrade for the kde-workspace package from a console. It worked for me.

I added unstable xorg ppa. Try to login to runlevel 3 and:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update && sudo apt-get dist-upgrade

It is bleeding edge repository but system works perfect for me.

Hi, well I upgraded the software packages via settings - update then rebooted and couldn’t log back in. How would I manually update software packages without logging in? I’ve used Ctrl+Alt+F1 but sudo apt-get upgrade doesn’t work. As you can infer, I’m new to Linux but love a challenge and would like to be up and running with Netrunner again. Thank you

What reason is it sudo apt-get upgrade doesn’t work?