Newly created user can't login

Hi, I created a new user account, added it to group ‘users’, and tried logging in to the new account. At the login screen, I enter the new user’s password, but then the screen darkens for a few seconds and returns to the login screen. This happens both when switching users from a session of my user account, or when restarting the system.

Also, sorry to threadfork, but should the login screen show the photo I associated with my user account? Mine doesn’t.

Hi Raymund,

both scenarios work fine here:

  • Avatar:
    System Settings - User Account - Account Details - Click on the image (or empty space) next to the username, select an image (for example from the default avatars), logout and it shows fine here.

Add User:
System Settings - User Management - Click “New” - Just flll out the username and leave usergroup and home to be automatically set correctly by the system, then Pick a password and that’s it.
So only username and password have to be picked, then a default user is added as a non-administrative account, and can log in fine here.


Thanks for the reply. I deleted the old user (created in terminal) and recreated it through System Settings > User Management. Worked just fine.

If I want to deny the new user internet access, I should uncheck the group “dialup”? And will that prevent the new account from being accessed remotely? (I don’t have remote access now, but I have plans of setting up this machine as an ssh server for my user).

Regarding the image at login, I had already assigned a picture to my user account. I removed and readded it, then logged out and back in, but still get the same generic icon.

Regarding the image at LightDM Login:
Can you pick one of the pre-installed images to check if its generally working?
What filesize and format (jpg or png) is your custom picture?
Maybe LightDM does only accept a certain format, then it is supposed to be a bug…

The pre-installed image didn’t work. Specifically, I picked one, logged out, and at the LightDM screen, only saw the generic person icons.

My custom picture is an 80 KiB .jpg

It’s working here. I tried with the green smilie picture, and it shows fine in lightdm here with my initial user.
I wonder if its lightdm or the system settings at fault over your machine.

I tweaked a few things in LightDM (aspect ratio and whether there’s a background image), no luck. Still getting the default icon.

I use LightDM 1.5.3 over here, what version do you have installed? (LightDM latest packages are 1.6).

According to ‘dpkg -s lightdm’, I’ve got:

Architecture: amd64
Version: 1.4.0-0ubuntu2

And from the “My Computer” page:

OS: Linux 3.5.0-27-generic x86_64
System: Netrunner 12.12
KDE: 4.10.2

Can you update lightdm?

Regarding the lightdm login image issue, I found a workaround here. Worked for me.

[quote]As a very simple workaround you can create a symbolic link so that linux sees ~/.face and ~/.face.icon as the same thing. By doing this, should you change your picture using the GUI, the picture will also change in the login screen.

Open a terminal (e.g. konsole) and type the following:
ln -s .face.icon .face[/quote]