No Audio Notification for Wireless lost connection

Verified settings for wireless,notifications are exactly the same for SolydK and Netrunner. Tho wireless applet versions may be different? As always had an issue with any distro my wireless for no apparent reason disappears from the list and connection is lost. Requiring me to manual de-select and re-select wireless button to get connection seen again and connect to it.

SolydXK KDE had audio notification when connection was lost. Which grabbed my attention when I wasn’t in front of the computer. Really helpful when downing an iso for an hour or two and intermittent lost of connection is possible.

Same issue with Netrunner when connection is lost.
I do not receive audio or popup notification. Even tho I have them both enabled.
And assigned audio alerts to all network settings listed. And test button plays them fine.

Is this a known issue? As kind of important to get a popup at least
tho prefer audio alert to wireless state lost.
Thanks as any help resolving issue is appreciated.

Did you try setting the notifications directly in the right click on networkmanager icon settings dialog ?

SolydK Home is based on Debian Testing and SolydK Business is based on Debian Stable, Netrunner rolling on the other hand is based on Manjaro Stable which uses new packages than even Debian Sid (Unstable). The KDE sound settings by default on Netrunner are not set up.

Like leszek said, the Network Management Settings dialog is where you would need to make those changes:

Yep looks like one I forgot to post and yep I have those set also which are just an extension from system settings>notifications. But right-clicking network settings in system tray shows I have assigned a audio file to everything there.

Still no joy on being notified when connection drops. That’s why I was wondering if it’s a new bug?
As still get notifications on file copying etc… So not the notification system.

Might be a bug. I never used notification sounds for that.
Also the networkmanager changed couple of versions ago to a completely new user interface.
Also sometimes in rare occasions maybe networkmanager takes a while or does not recognize directly that it is disconnected. Especially on weak wifi networks that might occur

Well get a ? mark on wifi icon in tray with no notification.
And yep me thinks it’s something new introduced in newer version.
As older versions still works normally.

This issue and the 1 out of 3-4 times booting hangs at clean /dev/sda5 and doesn’t boot to desktop. I can alt-F2 into a terminal and sign in and then startx and boots into desktop or just hard reboot. Something funky with systemd I suspect.

Only last 2 issues to resolve then a happy camper. And impressed with Netrunner Rolling. And outstanding distro that the dev’s & others that make it possible should be proud!


They are actually two separate applets:
kdeplasma-applets-plasma-nm - the newer version and
kdeplasma-applets-networkmanagement the older version which is still available in the AUR.

The problem is with SDDM not systemd as root either delete /etc/sddm.conf or follow this:

Yep renamed /etc/sddm.conf just in case. And rebooted and system generated a new /etc/sddm.conf file.
Losing all the auto-logon,user session,etc… A few lines in new conf file all = were blank.

As have followed that thread and originally renamed sddm.conf.pacnew to sddm.conf.

So must be me being dense as don’t see where I’m doing wrong?

So checked Octopi and and only version there and installed is Version 0.9.0+git20141003.ef14018-2
So guess it’s a mute point until .10.0.3 is actually available?


You’ll need to edit the new sddm.conf file for auto-logon,user session,etc.

kdesu kate /etc/sddm.conf

Just be sure to edit the appropriate sections.

Once the SDDM package get’s updated to version 0.10.0 it will rename sddm.conf to ssdm.conf.pacorig at that time I will have more instructions available.

Thanks for the help and yep just wait on the issue.
And taking a look into the wifi applet choices you presented.
To see if I can resolve the wifi notification issue.

Thanks again for your great help.