back to Netrunner | back to Blue Systems

No boot menu entry after installation


#1

Hi. I have an Acer Asprire E1-571 which boots via EUFI into Windows 10. Secure Boot is disabled. I booted into Netrunner Desktop via a USB and installed from there into a previously unused partition. No error messages noted during installation and the install routine stated it would use the existing EFI partition. However, on reboot, I only have my original boot menu, no entry for Netrunner.

If I reboot with the Netrunner USB, the target partition is formatted as Ext4 and contains all the files and folders I would expect.

How should/can I modify the existing Windows Boot menu to include the new OS?

Thanks is advance.


#2

Can you use your UEFI bootmenu to choose Netrunner?


#3

Hi Ieszek. Short answer is “No”. When the laptop boots it boots straight into the same menu as had prior to installing Netrunner. Just Windows 10, and the Macrium WinPE recovery enveironment.

However, If I explore the ESP partition I have folders for Microsoft and Debian. Si I’m assuming that I just need to get the Debian (Netrunner) boot option insto the current menu?


#4

Windows Bootloader won’t be able to boot the linux system however.

I would suggest to boot with the live system and try reinstalling grub-efi following this guide (adapt to your installed partition and use chroot for running grub-install)
https://wiki.debian.org/GrubEFIReinstall
(from “Reinstalling grub-efi”)


#5

Many thanks Leszek. I will try that out.


#6

Hi. I downloaded rEFind and burned it to a USB and because USB is the top option in my boot order it worked like a charm. Finds both Netrunner and Windows nd allows me to boot into either. Just need to pull up the courage to go through the GrubEFI process to see if I can persuade the machine to use Grub rather than Windows Boot Menu.

I did find an option in my BIOS to add an EFI boot entry to the boot list so I picked the NetRunner .efi file and moved that to the top of the list. Boots straight into Grub which has an entry to boot Windows. However, I I pick that entry, Windows goes into a Self Repair process and eventually takes me to the Advanced Startup menu. From there I can go into Windows with no issues.

Bit of a faff - but certainly workable for now.


#7

Good that you find a solution.
Windows needs to have “Fast Startup” disabled if you did not do that already.
See: https://www.windowscentral.com/how-disable-windows-10-fast-startup