I have the HP All In One Office Laserjet Printer: Laser Jet Pro MFP M225dw
and this OS does not find my printer. So I tried manually looking for it and
it is NO where to be found in the list!

WHY haven’t you updated the HPLIP by Now??

Netrunner 14 is an LTS release based on Ubuntu 14.04 LTS, this means that hplip would need to be updated upstream.

However, that printer needs a binary plugin (firmware) installed to work, open a console and type:


Select download and install the plugin from HP.


I installed it. But what is this suppose to do? Cause I went back and searched for it again in the install list and it still is not there.

I tried downloading HPLIP and installing manually but I got to the part where it asks for the Super User pass:


Please enter the root/superuser password:
error: Password incorrect. 2 attempt(s) left.
Please enter the root/superuser password:
error: Password incorrect. 1 attempt(s) left.
Please enter the root/superuser password:

This is where I am at right now and have no idea WHY it’s not taking my password. Is there some special secret Super User password, I should know about?

EDIT: Also, what OS and version do I select? It does not offer 14.2 so I selected Ubuntu version 14.10 - Is this right?

Well, I got past the password thing by using sudo prior to the line of data entered into the konsole.

But then I came to dependecy not found “libusb”. Tried to apt-get it and not found.

Though I looked for it in synaptic and found it IS installed. Now what? If I can’t get my printer to work,
this is not a viable OS for me.

Try following this tutorial from the hplip web site:

Note: First remove the hplip package installed from the repositories.

I am trying to go thru those instructions and got stopped here:

D. Change your working directory to the hplip-3.15.11 directory.


cd hplip-3.15.11

This is what I get when attempting a dir chg:
bash: cd: hplip-3.15.11: Permission denied
I don’t get why switching into a directory would be denied.
But then again… I’m getting permission denied on several things

I have tried getting into the folder a few different ways and am denied every time.

Now other things are going wacky! I can’t sit and mess with this. I need a working OS.
Take care