No Sound.

OS Information
OS: Linux 3.2.0-45-generic x86_64
Current user: karl@karl-System-Product-Name
System: Netrunner Dryland Second Edition
KDE: 4.8.5 (4.8.5)
Display Info
Vendor: nVidia Corporation
2D driver: nvidia

No sound.
Booting up my computer - for no apparent reasons and out of the blue a ‘Removed Sound Devices’ window popped-up:-
KDE detected that one or more internal devices were removed.
Do you want KDE to permanently forget about these devices?

The list of devices KDE thinks can be removed:
Output: HDA Intel, ALC662 rev1 Analog (Direct hardware device without any conversions)
Output: HDA Intel, ALC662 rev1 Analog (Hardware device with all software conversions)

I didn’t remove any of these devices!

I then clicked onto ‘Manage Devices’ button:-
In Phonon - KDE Control Module window, under Sound and Video Configuration “Device Preference” tab - Audio Playback Device Preference for the ‘Music’ Category -
the following devices are ‘greyed-out’:-
HDA Intel, ALC626 rev1 Analog (Hardware device with all software conversions)
HDA Intel, ALC626 rev1 Analog (Direct hardware device without any conversions)

The ‘Test’ button isn’t responding to any devices as listed under ‘Audio Playback Device Preference for the ‘Music’ Category’.

Under the “Backend” tab -
‘GStreamer’ is currently highlighted.

Alternative is ‘VLC’ Which one of these two should be utilised?

The ‘default’ button(s) don’t seem to respond either.

When clicking the ‘Apply Device List To…’ tab the ‘KDE Control Module’ window indicates that the item ‘Music (with ticked checkbox)’ is greyed-out.

Request help to restore sound.

Hi karleman,

Just confirm to permanently forget the devices next time.
Use gstreamer for now, vlc is there if you experience some issues, but really both should work fine, so it doesnt matter.

Can you make a screenshot of the devices list for audio playback?

Thanks, I did that - however it didn’t make any difference to the sound issue.

Well, I didn’t know if my “no sound” issue was related to either gstreamer or vlc, hence my question. I tried both but the problem stayed on.

I tinkered a bit with KDE-mix and Phonon and things had gotten gradually worse - the issues were too numerous to list down and therefore decided re-installing Netrunner. All’s back to normal now and the sound is back. I am not sure but suspect that the installation of NVIDIA graphic driver somehow contributed to the sound problem. I am going to run the system without NVIDIA for a while and report if the issue recurs after employing NVIDIA in a week or so. In the meantime this particular “No Sound” thread can be considered as solved.
Thanks for your time responding to this issue.