back to Netrunner | back to Blue Systems

Nouveau doesn't recognise chipset

Hi there,

I m trying to run/test netrunner OS from the USB before installing.
I get a message stating that nouveau doesn’t recognise the chipset.

It appears that the nividia GeForce GTX 1650 is not supported by the nouveau driver.

I cannot find an ISO image of Netrunner with proprietary NVIDIA driver preinstalled.
Can someone point me to a solution to get around the nouveau error and test/install netrunner on my laptop?

thank you

Do you get any graphica output so you are able to install the system already?
I am asking as the kernel 5.2 should give you support within the nouveau driver. Netrunner can use the Debian Buster Backports Kernel 5.8.10 which should also support your card with the nouveau driver.
So if you have the ability to install Netrunner just do so and activate buster backports software repository and update to a newer kernel 5.8

I haven’t had much time to look into it again. Basically, I booted from the USB and got the netrunner logo with 2 options. Cannot remember which option I selected but after that the message about the nouveau driver appeared on screen.

The next screen was like a terminal screen, but with few lines of text. I have no idea what I needed to type in there. I thought it was asking to instruct to bypass the nvidia card and continue with the integrated card for the installation. In any case, I wasn’t sure on how to get passed that screen and continue the installation.
:confused:

I see. So the graphical user interface is not starting for you. In this case you might want to try the “failsafe” option in the bootmenu. This should use a generic graphics driver and get the graphical user interface running.

Thank you for your replay.
I tried to install the system again. Failsafe boot goes into a black screen. So it appears that nothing is happening there.
I tried again the first option which showed the msg about the nouveau driver and unknown chip as per last time.
then it moved on to netrunner logo and loading up screen. Few seconds late the loading up was complete and the screen shown in the attached file appeared.

I typed “live” but that command obviously was not found. Not sure what I have to type there… apt install …

So even the failsafe graphics mode is not booting up. That is a bit unfortunate as it is not possible without recreating the live system for you to install it.
So sadly your graphics card is not supported by Netrunner out of the box.

If you have another computer and can install netrunner on the ssd/hdd of your laptop and then update the kernel from this other computer before putting the ssd/hdd back into your laptop it could work. But I am not sure if you wish to follow through this more cumbersome way of installing the OS.

Thank you for your answer.

Looking at the release dates i notice that Netrunner 20.01 was released initially in Feb 2020.
CPU i7-10750H was released in feb 2020 and the GTX 1650 was released in Nov 2019. I assume that support for this hardware couldn’t be included with NetrunnerOS 20.01 but it should be included with the next version of netrunnerOS.
Is there a new version of Netrunner coming up in the next 6 months?