Nvidia Drivers (Solved)

Thank you so much for the “new” Netrunner based on Debian. Just installed and everything went without a hitch. Beautiful desktop. I was wondering if you could give me the proper procedure for installing the Nvidia drivers in this distro? I can see the legacy drivers in Synaptic, but would like to install in whatever the recommended way is if possible. Thanks again for all the hard work in bringing this to us. It’s getting difficult to pick a “winner” from you guys, with all the changes happening lately. You keep outdoing yourselves :slight_smile:

Hi
I’m not sure why synaptic isn’t showing the nvidia-driver package ( I’ve reproduced it locally ). However you can install the newer package with the following command :

sudo apt-get -t jessie-backports install nvidia-driver

Hi there. Entering that command gives the following output…
E: Command line option ‘t’ [from -t] is not known.

Trying to take baby steps here :slight_smile: New distro with significant mods and not much info out there. There must be a thousand different ways of installing these drivers in Debian. I just want to find the “right” way of installing them into Netrunner Debian.

Hey
Could you paste the whole command you were trying to run?

EDIT: I see the problem : sudo apt-get -t jessie-backports install nvidia-driver

I also found the option in Synaptic finally, once you find nvidia-driver, Click on the entry in Synaptic, then on the Package entry in the menu and then on Force Version. Alternatively, selecting nvidia-driver and hitting Ctrl + E will bring up the version selection dialog :slight_smile:

Hi there. I’ve tried this way, and the Debian way, and the google way now :slight_smile: 3 installs and three unsuccessful attempts to install the drivers. I know we are going to have to get used to doing things differently now with the new base, but I think I am going to wait until someone who has successfully installed the drivers in this distro, chimes in with the procedure they followed.

Could you tell me what failed with the apt-get command?

It succeeds successfully here.

It goes through the process as you described. I get the error message about blacklisting the nouveau driver, and need to reboot. I ignored that as suggested. Then the message about no xorg-config. Which I download and install. When I reboot and it is supposed to create the new xorg file, I cannot get nvidia-settings to come up, either by terminal or gui. Can’t log into the desktop. What I am wondering is if I perhaps have to install kernel headers or something before I do the command that you suggested?

Hi
Yeah the debian wiki suggests that you have to install the linux headers. See https://wiki.debian.org/NvidiaGraphicsDrivers#Version_352.79_.28via_jessie-backports.29

OK, getting somewhere now. I followed these instructions under Jessie,
https://wiki.debian.org/NvidiaGraphicsDrivers#Version_352.79_.28via_jessie-backports.29,

and the drivers installed. However, on bootup now I get error messages, modprobe module microcode missing, and numerous errors about the virtualbox module as well. The other thing I’ve noticed is that nvidia-settings wasn’t installed. When I attempt to do that, it looks like it is going to remove a major number of files in the process, so I didn’t proceed. The drivers are active, and the system does boot up, not sure yet if there is anything else of concern.

Yay, I think the Virtualbox driver issues can be ignored because you’re not running on VBox. Microcode issues, huh, if you have iucode-tool and intel-microcode installed, it should be fine.

As for nvidia-settings, make sure you’re choosing the jessie-backports package with sudo apt-get -t jessie-backports install nvidia-settings

thank you so much shadeslayer for the help, and patience :slight_smile: the tools and microcode are installed and the system seems to be running and looking great. The backports package for nvidia-settings did the job nicely.

No problem :wink:

Could you please mark this thread as Solved?

Hi All
I know this is closed, and I am actually running Core, but I thought I would share if you have to use older driver

sudo aptitude -r install -t jessie-backports linux-headers-$(uname -r|sed ‘s,-,’) nvidia-legacy-340xx-kernel-dkms

This worked for me.