Nvidia Optimus

Hi, I’m new to Arch Linux and I tried installing nvidia driver using nvidia instructions in arch wiki
but I’m stuck in “nano /etc/X11/xorg.conf” and when i tried to create using “Xorg :0 -configure” I get this error:

"Fatal server error:
(EE) Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again "
How do I stop xorg so I can generate the Xorg.conf or tell me better way to use my nvidia gpu?

Netrunner Rolling is based on Manjaro in which is only based on Arch. Manjaro uses their own repositories, utilities and hardware detection sub system, they also stores some config files in different places than Arch does, Xorg configuration files are just one example of this.

To select and install graphics drivers under Manjaro there is a command line tool called mhwd (Manjaro Hardware detection), there also has a GUI tool for this as well, this tool can be used by opening up the Manjaro Settings Manager located in the menu under Settings, next click on Hardware Detection and from there you can install the free and/or non-free drivers, as well as setup and enable bumblebee on your system.

PS. Here is the link to the Manjaro wiki, not everything you could possibly need help with is in there, but it is a good place to start:

Thank you for the reply, I installed one of the option but now it’s just terminal. The screens is messed up too. Can’t startx either it produces errors “…is already active display 0” something like that. It flickers(not sure what the correct term). Like there’s two terminal switching very fast. I think I messed it up. I’m sorry for the trouble and for being a noob. :confused:

I’m using livecd now btw.

Are you trying to use the proprietary or the free drivers for the Nvidia chip?