Netrunner Home

Parition duplication and UUID changes (solved)


#1

Hi,

I know this topic is not very specific to netrunner, but as I am using this distribution, let’s post my question on this forum. I want to have 2 identical bootable partitions with Netrunner on the same disk. I was able to create the two partition, install on one, copy to the other one using dd command, and then update grub to see the two different boot possible.

The issue is the following: Desipte grub tells me that one boot is the default (on /dev/sda7) and other one is on /dev/sda5, in reality, if I list the mounted partitions in both cases, it is always /dev/sda7 which is mounted. So in reality, whatever boot I selected, I use the same partition… which was not the goal.

I thought this was an issue because I had twice the same UUID (due to the dd copy). So I modified the one of /dev/sda5 to avoid any confusion and re-run grub-update. But this didn’t change anything…

Then, I thought that the issue was coming from UUID stored in the /etc/fstab file. So I modified the /etc/fstab file of /dev/sda5 to put the UUID corresponding to the /dev/sda5 (replacing the initial one from /dev/sda7). But this didn’t change anything !

There is probably something else I should modify so that after a grub-update, I can really boot fully on /dev/sda5 and no more use /dev/sda7. But what ? Any idea or link to an explanation ?

Best regards.


#2

I suggest redoing it and use normal copying instead of dd’ing as it seems somewhere the uuid is still set to be the same for both.


#3

Hi Ieszek,

Thanks for your answer. But as far as I know, UUID is stored at the begining of the partition, so whatever tool I use to do the copy will provide the same result. Bus as there is a way to change the UUID afterwards, this is not a big deal at this stage.

Finally, after searching quite a lot, I found the following tutorial:

https://help.ubuntu.com/community/MovingLinuxPartition

I realized that I did everything until end of step 5, except the search/relpace in Grub.cfg file of the new partition (note that in my case, the step 6 is not necessary as I don’t want to get fully rid of the old partition for the moment). So I applied the proposed changes in grub.cfg of the new partition, and this worked ! I have now the right partition mounted, so I can boot on one system or the other. Problem solved ! :wink:


#4

Nice that you found a solution.