Permissions Problem Installing Printer Drivers [SOLVED]

Here is what I get when trying to install a Samsung ML-2880FW driver

**** Do you agree ? [y/n] : y
./noarch/package_install.sh: 46: ./noarch/package_install.sh: ./noarch/package_install.sh: Permission denied
**** Do you want to continue to install scan driver ? [y/n] : y
./noarch/package_install.sh: 46: ./noarch/package_install.sh: ./noarch/package_install.sh: Permission denied
**** Install finished.

How do I fix this?

I had it installed on MINT KDE 17 with No problems.

This may seem like a silly question but are you using sudo?

YES!

and now I’m in a chat with a Samsung tech and what a moron!
I tell him one thing and then he asks me if I did something after
I just told him I did it! Go figure…

Mr. Gupta… couldn’t help me and now they ask me to call back
tomorrow when their advanced tech support is in. Great.
(meaning, American support)

Can you enter the noarch directory and change the permission of the file to executable ?

noarch?
How do I do that?

Here is what I get when using the sudo command:

project13@project13-NY542AA-ABA-s5220f:~/Desktop/uld$ sudo ./install.sh
**** Running install …
**** Press ‘Enter’ to continue or ‘q’ and then ‘Enter’ to quit. :

Then I go through all of the terms and after the terms I say ‘y’ to agree and then it says:

**** Do you agree ? [y/n] : y
./noarch/package_install.sh: 46: ./noarch/package_install.sh: ./noarch/package_install.sh: Permission denied
**** Do you want to continue to install scan driver ? [y/n] : y
./noarch/package_install.sh: 46: ./noarch/package_install.sh: ./noarch/package_install.sh: Permission denied
**** Install finished.

Man… I tell you!.. Everything is YOU DON’T HAVE PERMISSION!
I hate it when I can’t even use my own computer!

I did NOT have this issue with MINT. But I had other glitchy issues with it and therefore came back to this distro.

There is a repository for the Samsung Unified Driver here: http://www.bchemnet.com/suldr/index.html
You have to scroll down the page for the instructions on how to add it and the gpg key, etc., I have a similar Samsung printer that uses the same driver, but since I run the rolling edition I only had to install it from the AUR. I hope you find this useful…

Can’t you right-click the link and save it somewhere in your home directory?

oops… I thought of that a little bit after the fact. So I deleted my last post thinking no one would see it that fast. 8)

Yea, sometimes I have had the same issue, lol. :slight_smile:

Well, i installed this file as instructed on that site, but what do I do with it now?
I still don’t see my printer in the printer list.

I installed the .deb files from the Samsung website and did what they suggested, though none of it has worked.

Why can’t I simply enter the ADMIN acct for this distro? I could install it there and be done!

Man… this was a BREEZE on MINT. WHY is it sooooo hard on Netrunner??

So you went to the printer manager and tried to add your printer ?
Did you try restarting the cups printing server ?

sudo service cups restart

You honestly want to login on a graphical desktop as root ?
This is not adviced and not recommend. Btw. one of the reasons root account is deactivated on Netrunner.

So then why do other distros allow you to do this?

From where? Pardon my ignorance… 9/

But I did not see anything of such in the list

Did you select the suld-driver-1.00.21 package?

I can’t find this printer (Samsung ML-2880FW) on the Samsung site, the closest I can find is the Samsung Printer Xpress M2880FW:
http://www.samsung.com/us/computer/printers/SL-M2880FW/XAC
Support page:
http://www.samsung.com/us/support/owners/product/SL-M2880FW/XAC

Is this the printer you have?

If so then the unified driver version listed on the site is V1.00.27.04, I don’t know if that one is in that repository yet,

This is it:
http://www.samsung.com/us/support/owners/product/SL-M2880FW/XAC

Well, like I said… I had NO problems installing to MINT. So WHY in this distro is it a problem?

I’m not sure, but like I said the Samsung support site has an even newer driver than the repository does. You could try the suld-driver-1.00.21 package from that repo and see if it works other than that, I have no idea why the script is failing on Netrunner Frontier, it is based on ubuntu 14.04 the same as Mint 17…

Installed the suld-driver-1.00.21 package

That got the printer working, but Not the scanner.

You could try the utility suld-configurator-2-qt4 in that repo to set it up, also is sane installed?
Sometimes scanners can be a little tricky, even with the right drivers installed, I have an HP that took a reboot for it to work.

You may also need this for the scanner: suld-scanner-usblp-fix

Yeah scanners on multi devices almost always need a udev restart to be recognized. The easiest way is just simply reboot the pc.

I GOT IT WORKING!!

I took the advice to set permissions to the file and it worked!
It took me a while of thinking about this to realize what you meant.
This stuff is all new to me… really.

But here is proof I got the scanner working… it is a scan of the Samsung disc.

I’m so glad you got it working, Using Linux is always a learning experience, even with the most user friendly based distributions. I’m still learning new thing all the time and I’ve been using Linux since 1996. :slight_smile: