Plasma 5.5.3 blow every thing up!

Hey there
I have newly installed the horizon version of Netrunner. after installation every thing runs nicely and even I update the kernel to the latest version. after restart the system was still stable. but after
Sudo apt-get update && sudo apt-get upgrade
the desktop is black and I can access the KDE menu.
the error is

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/main.qml:27:1: module "org.kde.plasma.private.kicker" is not installed

when I click on the KDE menu and I can’t even update any packages!
would you please help me to solve the problem?

Seems like the update failed to install successfully.
Can you run sudo apt-get update && sudo apt-get dist-upgrade manually from the terminal ? Does it update anything ?

Hi there,

I am facing the same issue and I nearly tried every suggested solution I have found on the internet to no avail. I have googled for this problem in connection with Kubuntu mainly…
After some months of not using Linux, I finally went back to install Netrunner 17 on a Workstation 11 VM on my WIndows 8 host. I was very excited to use Linux again for my private computing, but now I am struggling since two days with the issue described above.
Here is what I did:

  1. Created a VM with standard settings in VMware Workstation, VM type: Ubuntu 64-bit (note: I am using a physical disk directly as my physical hard drive)
  2. Installed Netrunner 17
  3. After logging in with my password, the desktop is blank. I can still open the terminal and I do see my mouse cursor.

I updated Netrunner via the terminal as suggested above and I have installed the most recent Vmware tools via command line as well. All to no avail.

Quite frustrated to be honest, I really would love to give Plasma a try and I have been using Netrunner very hapily for many months in the past, it was my most favorite Linux distro.


Neither terminal nor Muon updater don’t update completely.
Muon updater is more freaky while it shows notification about available updates but it does not show me any thing and it just tries to refresh the list!!

I tried both wireless and cable Internet and in addition I tried VPN connection to access Internet. None of them worked for me.
Again I wana mention that after upgrading the kernel everything went excellent but after updating the packages (using terminal), I lost the KDE!

I wonder what would be the cause of this. Normally you get a big fat warning message if it wants to remove software packages already installed ?
Did you not see that or clicked that away ? Or didn’t it appear ?
Do you have any logs/screenshots or something that might help identifying the problem ?
Did you run stock Netrunner 17 or did you enabled installed any third party ppas ?

In fact I got GPG error during the update via terminal. By using the code below

software-properties-gtk --open-tab=4

I opened the software & updates windows and unchecked the ( stable menu)and then I could finish the update process, but same problem still can be seen.

New edit:
I changed the server to the best suggested server and new updates approached. after several update I reboot the netrunner and oops!
I don’t have login page!! after Netrunner logo the black page is all thing I have! I’m writing from Microsoft Windows 10 and I really miss my stable Netrunner. :angel:

I installed 17 Horizon some time ago (when it was first released) and got the black screen after update in terminal. I gave up on it and deleted after many reinstalls. Today I installed clean again because I recommended it to a friend in Angiers, NC. So, I figured I better get on the ball.

New install and in terminal updated. Nothing else was installed and did not even open Muon Update. I rebooted and it loads through the Netrunner and 9 dots. Then all black. I reinstalled different ways to no avail. I then removed dvd an restarted in recovery mode. Activated Network 1st. Repair packages @ 290 mb. At the end I selected y and entered.

After restart I can now log on. Tried it again and again I can log on. I will use terminal update again and see what happens. I will use the same: sudo apt-get update—sudo apt-get upgrade. If it breaks again I will go the 3rd step: sudo apt-get dist-upgrade after a new recovery mode repair. I will be back again soon I hope. Do want friend to have a good first time experience.

UPDATE: Again, in the terminal, sudo apt-get update then sudo apt-get upgrade it only updated Python and update packages and no problems yet. Working very well. Even seems to load much faster and work faster also. Don’t know if it will last. See ya tomorrow.

I hope it works for others too.