Plasma crashes when shutdown or restart

Is there a way to get to a regular terminal? Trying "sudo apt-get remove nvidia-* from the root shell prompt results in

W: Not using locking for read only lock file /var/lib/dpkg/lock
E: Unable to write to /var/cache/apt
E: The package lists or status file could not be parsed or opened.

That’s strange indeed as there should not be another app running that blocks apt-get. It seems to me that it is mounted read only. This would mean you need to boot normally and switch to a tty by hitting ctrl+alt+f1 for example.
From there the command should work

ctrl+alt+f1 (or any other fkey) isn’t working. I just have a black screen. I should have just stuck with the weird icon text because other than that it was working and now it won’t even boot and I have no idea how to fix it.

Please use a live system to attach the /var/log/Xorg0.log file.
Also try editing the booting parameter in grub by pressing e on the entry and removing the [b]quiet splash[\b] parameters and while still in that editing mode pdessing Ctrl+x to boot.

Here’s the Xorg.0.log. I removed the quiet6 splash but it still shows no text or anything while it attempts to boot. Right after choosing Linux from grub, it goes black. It makes no noise, there is no text or cursor and looks like it has shut down. But if I click the power button it briefly shows the Netrunner logo then goes black again.

You seem to have an optimus based system as I can see nvidia and intel driver loading. That might explain the issues.
Can you turn off the intel or nvidia card in bios? That would nake things easier when it comes to getting a graphical user interface again.

I can only set it to either Discreet or UMA only. UMA only will use only the Intel integrated controller, which means I won’t be able to play any of the games that I bought this for. I need the Nvidia card to work again or it’s useless.

ETA: I switched it to UMA only even though it isn’t acceptable to leave it that way, and it still won’t boot but now I have text on the screen that says
bbswitch: No discrete VGA device found.
Still cannot access tty this way, either.

recovery mode dose mount the system ro ,you can once booted to recovery do

sudo mount -o remount,rw /

to get rw ,mite not need the sudo ,cant remember


When switching it to UMA only didn’t work, I switched it back to Discrete and then it booted! Screen size and resolution was off but it look right after resetting those. I went into the Nvidia settings to set Nvidia as Prime since this computer is always plugged in, but it was already set to Nvidia. Do you know if there is any way to make it NOT try to switch back and forth but just use Nvidia all the time?

It still shows the icon text all screwed up after sleep but other than that it seems to be working.

I had tried sudo mount -0 remount,rw /dev/sda10 but it didn’t work. Said it could not be mounted or that it wasn’t mounted, don’t remember for sure.

you do not add the /dev/sdxx ,just / (exactly as posted) you are remounting / that is already mounted . you are just changing the ro (read only) to rw (read write)


OK, thanks. I’ll try to remember that.


I do not know if it will cure your problems but this may do it for you. I had major problems after an update in the terminal after fresh install with the black screen at boot. I use an asrock motherboard and it is nvidia ( I think ) also, built-in.

The following is the post:

p { margin-bottom: 0.1in; line-height: 120%; }


I installed 17 Horizon some time ago (when it was first released) and got the black screen after update in terminal. I gave up on it and deleted after many reinstalls. Today I installed clean again because I recommended it to a friend in Angiers, NC. So, I figured I better get on the ball.

New install and in terminal updated. Nothing else was installed and did not even open Muon Update. I rebooted and it loads through the Netrunner and 9 dots. Then all black. I reinstalled different ways to no avail. I then removed dvd an restarted in recovery mode. Activated Network 1st. Repair packages @ 290 mb. At the end I selected y and entered.

After restart I can now log on. Tried it again and again I can log on. I will use terminal update again and see what happens. I will use the same: sudo apt-get update—sudo apt-get upgrade. If it breaks again I will go the 3rd step: sudo apt-get dist-upgrade after a new recovery mode repair. I will be back again soon I hope. Do want friend to have a good first time experience.

UPDATE: Again, in the terminal, sudo apt-get update then sudo apt-get upgrade it only updated Python and 3 update packages and no problems yet. Working very well. Even seems to load much faster and work faster also. Don’t know if it will last. See ya tomorrow.

It is holding its on so far

The recovery mode details are not complete but you will see them as you do this.