Plasma crashes when shutdown or restart

After fresh install of Netrunner 17 I can confirm that Plasma crushes every time I shut down or restart my comp. It’s definitely not my fault - only thing I did was update system, install graphic drivers and few apps from Discover!

The comp actually will shut down or restart but plasma crushes before that and I can’t really report it because that crash notification window only lasts for a few seconds and then shutdown or restart process continues anyway…

Ok. I tried to stop the shutdown with quickly pasting “killall shutdown” in Konsole as soon as the crash happens…

No luck - terminal just replys “no such process: shutdown” or something like that…

Anyway, what exactly happens is thins:

  • I press the red shutdown button in lower left corner of the main menu from the main panel
  • my screen goes black but I can still see and move my mouse cursor (little whit arrow), this lasts for a few seconds
  • then I can see my desktop wallpaper again but it’s little dimmed and I see this message:
  • then if I click report bug or something - additional window appears and screen returns to normal (it’s not dimmed any more). Sometimes another error message will appear again (same as first one) if I try to do something. After few seconds the comp will actually shut down so there’s not much time…
  • I managed to quickly grab a screenshot with some details before comp powered off but the screen is still dimmed here as you can see:

Hopefully this helps and my several consecutive shut downs and power ons were not in vain… :stuck_out_tongue:

Is this thread still open? Because plasma also crashes for me with every single shutdown or reboot. It also crashes every time I log out.

I have the same problem know. Waking up from suspension works fine, but when I shutdown the computer I get KDE’s error message. It was so since the day I installed Netrunner 17 in December.

Did you perform the update to Plasma 5.5.3 already?

I don’t know if you meant me or the OP but I’ve got 5.5.3.

I fear it might be this problem here that also hits the Netrunner Rolling release:

Investigation will commence after Karneval is over here :slight_smile:

In the meantime can you attach a log of ~/.xsession-errors as it might contain maybe an error message.

For this bug I attached is one of the Plasma crash bug reports that I passed along to sho_.

Good then we need to chat only to the right guys on IRC and ask them “what the heck is going on” :slight_smile:

Nice then let’s hope he finds a solution.
We will keep everyone informed in this thread.

Just to make sure for everyone: workaround number 1 currently is removing all desktop icons.

Thanks. At least the workaround is easy. :slight_smile:

We uploaded an update to netrunner-desktop-containment which should fix this error now even with desktop icons present.

I can confirm it’s now fixed. Thank you for all hard work!

After the update, I get a weird random noise pattern behind the text of my desktop icons which clears on a fresh login but comes back after sleep. It wasn’t quite right before the update either, not beiing transparent so my wallpaper showed through like it should, but now it’s much worse and unreadable.

Seems like your graphicsdriver has a general issue with this. Can you try switching the driver if possible?

Apparently not, since now it won’t even boot. It was using the correct Nvidia driver for my card. I tried switching to the Nouveau driver and now it won’t boot. I get a black screen that says The control interrupt lied. I have no idea how to switch it back from command line and don’t even remember exactly what the correct driver was. :frowning:

Oh. Yeah thats a different issue. But try the failsafe booting and reinstalling the driver somehow or remove it completely.
In Failsafe you should be able to boot into X and Plasma so you can use the Driver Manager there.

Is failsafe the same as Recovery? If I choose Recovery on boot, the only option on that screen to boot into X is Resume Normal Boot, which fails.

ETA: Isn’t there supposed to be a failsafeX option? Because I don’t have that in the menu.

Hmm yeah thats what I meant. Can you remove all the nvidia packages on the terminal in recovery then?

I do have the option to drop to root shell prompt but I don’t know the commands for removing the nvidia packages. I don’t use the command line much. Also, it only failed to boot after switching from the Nvidia driver to the Nouveau one so it shouldn’t be trying to use the nvidia packages now, should it?

Iam not sure what’s wrong you can take a look at /var/log/Xorg.0.log to see what’s wrong with the Xorg and why it does not start.
You can use sudo apt-get remove nvidia-* to remove all packages starting with nvidia-