Netrunner Home

"plasma tweaks / desktop theme / Air" freezes GUI (mousefocus stolen)


#1

last post has a workaround. But then, several themes are nicer than “Air” , anyway…


I said it many times now.

The “Air” theme is broken such that it freezes the whole PLASMA-SHELL which is your desktop, right.

still everybody (every distro) ships it even though there are tons of alternatives which do NOT freeze the GUI (“no seams” is nice!)

be it as it may. this was the last calling :sleepy:

[hr]
so obviously I ask our NETRUNNER distro maintainers to drop the AIR theme and to no longer ship that decorative poisoned desktop theme of no particular relevance whatsoever.

“Air” is poisoned, broken code and more trouble than it is worth. Other themes are just as nice btw.


#2

You do realize there is no AIR package?

The air theme comes as part of plasma-frameworks, and is one of the plasma 5 default themes, just as oxygen was for Plasma 4.

If you have any issues with the air theme, you should file a bug report with the KDE project here.
https://bugs.kde.org/


#3

yeah , well, you better stand up against this poisonware


#4

Excuse me?
You want to make a suggestion fine.
But, don’t you ever tell me what I “better do”, you have no authority over me.
Frankly, I have no issues running AIR on my machines, just as I have never in my life needed to use xrandr to correct a garbled screen.
[attachment=1138]


#5

thats pretty cool dude

u must run some special hardware … maybe “screen” is inapropriate of a term here - interesting … yes


#6

just saying , yes, AIR breaks machines , so lets drop that cräp, right…


#7

No, I actually run a variety of hardware from laptops, to desktops, to all-in-ones.
My test bed at one point and time had over 6 systems in it, now it’s only 3, but still.


#8

Now, with that said, I’ve been running AIR on this machine for over an hour and no freeze, crash, or lockup, so far.
I’m going to keep it this way until tomorrow, or until I have an issue.
Let’s see what happens, shall we.

Just fyi:

inxi -F
System:    Host: james-pc Kernel: 4.17.19-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.13.5 
           Distro: Netrunner 2018.08 Rolling 
Machine:   Type: Desktop System: HP product: 24-g227c v: N/A serial: <root required> 
           Mobo: HP model: 82DD v: 0000 serial: <root required> UEFI: AMI v: F.36 date: 06/21/2018 
CPU:       Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP L2 cache: 3072 KiB 
           Speed: 643 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 4: 700 
Graphics:  Device-1: Intel HD Graphics 620 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.1 driver: intel unloaded: modesetting tty: N/A 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 18.1.8 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.17.19-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: c8:d3:ff:e7:c4:47 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be 
           IF: wlp2s0 state: down mac: be:6c:c5:b6:cc:e2 
Drives:    Local Storage: total: 1.82 TiB used: 528.91 GiB (28.4%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1SB102 size: 931.51 GiB 
           ID-2: /dev/sdd type: USB vendor: Western Digital model: WD My Passport 0827 size: 931.48 GiB 
Partition: ID-1: / size: 881.71 GiB used: 38.33 GiB (4.3%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 34.43 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 192 Uptime: 1d 20h 25m Memory: 31.30 GiB used: 2.06 GiB (6.6%) Shell: bash inxi: 3.0.2
inxi -m
Memory:    RAM: total: 31.30 GiB used: 1.81 GiB (5.8%)

#9

OK, 3 hours+ with the screen blanking twice when I was away from system, and once wakening from suspend, still going strong with no issues so far.

Well, It’s late and I’m going to bed now, let’s see how it goes in the morning when I wake this system from hibernate.
If that goes well, I’ll keep it this way all day tomorrow as well…


#10

Well, it woke up from hibernate just fine, no issues what so ever.
Still going to run this system using the air plasma theme until later tonight.

NOTE: I’m beginning to think that maybe, your confusing Air with the Oxygen bug of freezing the desktop when removing widgets.


#11

Still no issues.
I also just did a quick google search for any other reports of AIR causing issues, and found nothing.


#12

OK, going back to AlphaBlack, all that white was getting to me.
I still had zero issues with Air, there was no freezing, crashing, or anything else negative happen during 2 days of normal usage.


#13

#14

And yet, your the only one I’ve seen so far reporting this “issue”.

Your not overclocking, or doing anything else unconventional with your systems I hope?

The reason I ask, what your describing sounds more like a hardware failure than a theme issue.

I have seen what your describing before, but it had nothing to do with a theme, but was typically a driver setting and/or bug. In one case it was the opengl settings in the kwin compositor that were wrong, in another instance it was an x11 driver setting.

Just a thought, but could it not be possible that this theme may just be the trigger in your case, and that some other setting, and/or driver combination your trying to use, is not actually supported by your hardware, causing these issues?

PS. I’m running the same test on two of my other systems, and still no issues with them either.


#15

no, I’m not overclocking.

It’s possible that not directly AIR is at fault but this is sort of tricky to narrow down for me.

Also, people kept telling me all my life that I am the only one person in the world who complains about a certain thing, it is the oldest trick in the book, like calling people antisemites for no reason. kinda lame.


#16

We do not ship Air extra and cannot easily remove it as any update would bring it back being part of Plasma defaults.
As said, please open a ticket on official KDE bugs forums.


#17

with latest NRR 4.18 kernel etc. here is the bug report:

all themes work, except “Air”

upon freeze,

[list]
[]an empty small grey notification window (or plasmoid or wtf) is shown
[
]no keys or mousebuttons work except Alt-TAB and Alt-SPACE, so in krunner , ksysguard can be launched
[]so it feels as if the KBD + MOUSE focus is “away”
[
]related KDE bugs are pretty chaotic to follow or to make sense of
[]load on one of the cpus is 100% on the plasmashell process constantly
[
]when attaching nemiver to process “plasmashell” it coredumps of course
[*]ksyslog gives various output difficult to make sense of
[/list]


#18

here is a workaround that worked for me:
now the Air theme no longer freezes on occasion so far, so the root cause cannot be the “Air” theme itself, I guess.
but there seems to be a bug still hidden somewhere…

post scriptum : sorry, I found that the fix is worthless. e.g. “right click / unlock widgets” immediately silently freezes KDE (“daemon seems to steal focus”). I went back to a different theme. Cannot narrow down the problem.

let the bug live and prosper in the codebase.

fix this: sudo leafpad /usr/bin/startkde

KDE_SESSION_UID=id -ru
export KDE_SESSION_UID

XDG_CURRENT_DESKTOP=KDE
export XDG_CURRENT_DESKTOP

insert these lines:

export QML_IMPORT_PATH=$QML2_IMPORT_PATH

#disable QMLCACHE here
QML_DISABLE_DISK_CACHE=1
export QML_DISABLE_DISK_CACHE


#19

Like I’ve said before, I could not reproduce this issue on any of my test bed systems.
With that said, If those tweeks work for you then great.
However, others need to keep in mind that such modifications are use at your own risk.
Any deviations in base system settings from what we ship, make virtually impossible to track down, and/or reproduce, any issues that may arise from that point forward.