Plasma won't start after update [SOLVED]

Hi guys,

I just installed the last update package, rebooted and Plasma won’t (fully) start. I have a mouse and a KDE splash screen but it gets stuck loading forever. When I tried to restart X, I got a message “Cannot open theme file /usr/share/apps/kdm/themes/manjaro-style-kdm”. I did startx in another shell and changed the login theme from a default KDE session, as it was suggested in another thread, but it didn’t really work. When I restart X now I get a login screen but when I enter my credentials, the bootsplash gets stuck again at the same place. Tried different kinds of sessions but it’s all the same.
I played around with .kde/share/config/ksplashrc but it didn’t help. Plasma just doesn’t start with or without a splashcreen. Any ideas?

Seems like you are running kdm which is not used by Rolling by default.
You can change the kdm config with systemsettings when you run it as root.
If you can login as root that is.

The other option would be editing the kdmrc config directly which should be under /etc/kde4/ if I am not mistaken

Edit: See also this post with the same topic :

I’m just curious, trying to learn the Rolling system that I just got into recently.
By any chance have you changed the default setting on the Rolling, and perhaps that is of the unwanted consequences after an update?

After a bit of poking it turned out that I had no space left in ~. :smiley: Deleted some stuff and I got Plasma back on.

It turned out that indeed the display manager is KDM (no idea how that might have happened). I changed the default to SDDM through systemd but the “Other -> Login Screen” menu still says DM is KDM. The whole startup is not very smooth - I have to make a few attempts with different sessions to get it working. I suspect there is still some conflict between KDM and SDDM. Is there any other configuration I have to change? I tried to find a SDDM log file but I couldn’t.

Yes, the “Other -> Login Screen” menu is for KDM, the problem is is that KDM is not a separate package on Arch/ Manjaro based systems and is part of the kdebase-workspace package and can not be removed. SDDM can be configured using the “Startup And Shutdown > Login Screen (SDDM)” menu.

To enable SDDM:

sudo systemctl enable sddm.service -f

The Plymouth package itself does not include a sddm-plmouth.service file like it does for GDM, LXDM, KDM, etc. so I had created one myself, I posted it in this thread about Plymouth not showing at boot along with the instructions on how to fix Plymouth as well:

Yes, that is part of the problem. :slight_smile: I removed PulseAudio and along with it some scripts and configs that could be causing such problems after an update. Anyways, that’s a great learning experience and such problems are to be expected from a rolling distro. I want my machine configured in a specific way and I’ll tweak and adapt it until it dies completely.

The system is running almost OK for now so I’ll mark the thread as solved. I think I can figure it out how to fix it if it breaks again.
Thanks for the help guys! Awesome as always!