PlayOnLinux

The version of PlayOnLinux in the Repository is 4.2.2. I am having trouble installing OFFICE 2010 with it. PlayOnLinux returns the error message: Error in POL_Shortcut Binary not found: WINWORD.EXE. OFFICE instals when using PlayOnLinux Version 4.2.1. I can find the package for 4.2.1 online, but I’m behind the learning curve here because I have always worked with DEBIAN before. I love this 2014.04 release. How do I get PlayOnLinux version 4.2.1 installed on it. Be kind I am really a newbie with Manjaro/Arch :smiley:

You will have the same problem with version 4.2.1 as well, it’s a setup issue not a version one. While installing Office 2010 you need to select to install all components to the drive, otherwise you will get this error.

??? 4.2.1 worked fine in ENIGMA. 4.2.1 came with the DISTRO. First install I UPDATED the repository first and it came with 4.2.2. No problem with 4.2.1, the problem is with 4.2.2. I don’t have all of OFFICE, just WORD.

OK, bit did you tell the installer to install all to the hard drive, the default does not, otherwise you could make sure the wine bottle that has word installed had access to the cd,

Have no clue what you are talking about. There is no telling the installer to install all to the hard drive. The DVD only has WORD on it. setup.exe executed from PlayOn Linux comes up with the same error for all the other components of OFFICE 2010 which aren’t there and that’s expected. WORD is there on the DVD it just never gets installed in 4.2.2 and I don’t know why. 4.2.1 works fine but I don’t know how to install 4.2.1 to NETRUNNER 2014.04. This is my first adventure in to ARCH. I came from DEBIAN.

To be blunt you can’t, that package no longer exists in Arch Linux. The point of a rolling release is to always have the latest versions of the software we use.

Please don’t take this the wrong way, I’m just trying to understand your issue better. What your saying is that if you upgrade to 4.2.2 on Ubuntu you’ll have the same problem?

PS. Ubuntu sets some things up for you that Arch isn’t going to, this is why I said it may just be a configuration issue, Arch packages for the most part expect the user to know how to configure things themselves. I don’t have Office 2010 to test with, and I don’t use pirated software as a moral choice.
[hr]
Are you using 32bit or 64bit Netrunner Rolling?
[hr]
And what is your video card?

First you are assuming my WORD is pirated it is not and I have a valid key

Yes on UBUNTU if I upgrade to 4.2.2 same problem.

I’m using 64 bit Netrunner Rolling. The WORD Install disk has both 32 and 64 bit versions I tried both with 4.2.2 and same failure

I have a NVIDIA Card, and you didn’t ask, but I do have NVIDIA 32 bit drivers installed. Error in POL_Shortcut Binary not found was expected for the OFFICE components not on the disk, but not for WORD which is on the disk.

This is what I wanted to know.

Have you tried q4wine instead?

Here is a nice tutorial:
http://www.youtube.com/watch?v=951nVQQJhks

Looking through the forum other people have also reported this. And the original bug report has been confirmed. I guess I wait until there is a solution. I need the INSERT EQUATION function in word. There are work arounds with LATEX, but the setup was difficult enough in Ubuntu which I am familiar with.
[hr]

No. Thanks I’m off to try it now.

In the interest of time I went back to NETRUNNER 13.12 64-bit which has PlayOnLinux 4.2.1-1 before upgrading packages. OFFICE 2010 is installed. So I guess I will wait until someone solves the problem in 2014.4 with POL 4.2.2.

UPDATE TO MY ISSUE: Really wanted to stay with a Rolling Version, and the MS Word install issue with PlayOnLinux 4.2.2 wasn’t going to turn me away. I am completely weaned from MS now and I can thank this version of Netrunner for it. I used Word because of its Insert Equation function. I write a lot of equations. GNU TeXmacs looks like it is going to do the job. So no Wine installed.

It took me a bit to set up SAMBA without the UBUNTU config GUI. I’ve set up SAMBA before without a GUI but the CLI commands are different in ARCH so I had to learn them in order to setup Users. Done. Changing permissions on /etc/samba/smb.cong.default so I could save as smb.conf was a snap using Dolphin. I only need the default shares for the moment.

So the result here is that the stack of a dozen or so iso’s I have of various Linux versions has been filed away and I’m sticking with this one.

Thanks for the responses. :slight_smile:

Great to here it, can I ask do you have the ability to share folders out to the network from within Dolphin? If so how did you get it to work? I don’t usually use Samba (I’m more of a NFS guy), but other have asked this in the forums.

I don’t know yet mate. I’ll work on it in the morning. :slight_smile:

I just found this it might help:
http://flexion.org/posts/2013-01-microsoft-office-on-arch-linux-and-ubuntu.html

I couldn’t let this rest so I came back and solved it. Even though my Word install disk supports both 32bit and 64bit installs it would not install on a 2014.04 64bit system. It does on other 64bit systems. So I installed a 2014.04 32bit system and I am up and running.