back to Netrunner | back to Blue Systems

Possible xinput2 issue?


#1

Not really sure how to go about posting this issue but… Basically I want to use Lutris to run some games. Lately there has been some updates to the runners they use. The last one that worked for me is 4.12.1, and when I asked why I couldn’t use 4.13 (and now, 4.15) I got a little help from someone in their Discord, yet this is the last message I received on the issue:


Any ideas why it wouldn’t be working for me on 19.08? 4.13 didn’t work on 19.01 either so I can only assume it has something to do with Netrunner in general. I tried asking again in their support chat but sadly I didn’t receive an answer this time.


#2

Do you have any console output or debug messages that can help?


#3

Not really, that I know of. He had me run a script that shows all inputs, and it picked up the movement from my mouse as well as the buttons. What output would I look at? The main issue is my mouse works in Overwatch menus, but not in-game. I move the mouse around to look around, and it does nothing. Though I can use the buttons on my mouse as I’ve always been able to.


#4

It is still weird.
I never heard of a mouse not working in the game though working in the menus.
Are you sure in the settings of the game you have everything setup correctly?


#5

Yes, as far as I know. If I switch back to 4.12.1 it works just fine. Any version newer than that though, no in-game mouse detection. I’m not sure how to do tests to get around to a solution.


#6

Maybe you can try replacing your installed wine version with wine-development which is a newer version and might fix the issue for you.


#7

When I try installing with sudo apt install --install-recommends winehq-devel I get:


#8

And what if you try to install wine-development?


#9

Ah… my bad, got it. Sadly it doesn’t fix the issue. Still no mouse movement in-game.