Post Install Boot up Nvidia HDMI

Hi All

Been distro jumping lately, so picked up a few tips along the way.

One of the main ones is adding nomodeset to grub when booting, usually this was needed to boot live usb, or sometimes the main install and was usually never an issue.

Live USB booted fine, I get the usual dead screen on my TV, but eventually the desktop pops up, so installed with no issues. On first boot no desktop, so thught no issues, edit grub by pressing Esc at the grub menu then edit a before quiet splash.

My SSD drive is onfire from the multiple restarts. I tried nomodeset everywhere, just after the ro on the UUID line and before spalsh, I have trieeed vga=, tried everything, the best I get is a flashing tty screen that only allows random inputs, if I do eventually get my login and password, it just says it cant load.

Using Tab just shows me lots of information, but no mention of nomodeset.

Where the heck do I add a nomodeset or variation off in the grub menu :huh: to allow me to boot into a new install please

Thanks for any help

Latest Rolling Release
Nvidia 650 Graphics card

Edit /etc/default/grub and don’t forget to run

sudo update-grub at the end so the grub config really gets updated with your nomodeset setting.


But I am only at the boot options, do I do that from the command line ?

Exactly at the command line


What option do I put in ?

edit : the command line at grub does not understand edit or sudo ?

The command line at grub only accepts grub commands not normal bash commands.
The commands above are for the installed systems bash terminal.

That was the problem though, I can not get that far.

If did get to a prompt, it was after I put in a nomodeset of some sort, but the screen or prompt was not static, and almost impossible to input text. As I said first time I have had such severe issues, I tried both versions of Netrunner previously, so something has changed for the worst.

Then just in the grub menu choose the boot entry press e to edit the boot options and on the linux line add the nomodeset bootoption and press Ctrl-X to boot with that options. Then you can enter the above bash commands.

Of course you could also use a live system to chroot into the installed system and update grub that way. But the first option is faster.

As I said I did try, but the screen was jumping about and some letters ended up the top of the screen.

I did intend modifying it from inside the Live USB post install, but documentation is either out of date or non existant
No mention in read me for Live CD password, if you search Google for 64bit live cd you find nothing, all you see is 32 bit and login and password as Manjaro, which never worked.

In the end I gave up as I did not want to waste all day sat with a broken system, so I just re-installed LM17 KDE.

Shame because I had an inkling to try it, I don.t understand why things have to change on boot from a Live to Install option, and why I could boot up ok in Manjoro, ah well. Thanks for your help anyway.