power buttons dont work after updating

Hi guys, first off all, I would never normally bother signing up to a forum when I have problems with a distro. Usually I just get on with it. BUT I love netrunner, I have been on many linux distros, and have finally found one I love.
When I installed ISO on my thinkpad, every worked dandy.
After a bit of playing around I ran ‘sudo apt-get update && sudo apt-get upgrade’ to get all my packages up to latest versions.
After doing this, the power buttons in start menu no longer do anything. And my volume buttons are no longer able to alter the volume (this worked before).
Any experienced similar?


Make sure you don’t have the xserver-xorg-input-joystick driver package installed after the update, this causes issues with the some media keys. http://packages.ubuntu.com/lucid/x11/xserver-xorg-input-joystick

Thanks for the input, i’ll have a look into that.
I also get this message after I log in while the desktop is setting itself up.
“Error launching /home/myUsername/.kde/Autostart/preload.desktop. Either KLauncher is not running anymore, or it failed to start the application.”
probably something to do with it.
Its strange as on some boots my volume keys and power button on the start menu work fine. Other times they don’t. Is funny one. Its not hampering my enjoyment of a great distro though.

Yea, that is a strange issue. If it was the media keys on the keyboard being intermittent then I say a static charge issue or the joystick driver problem I already described, but since your having an intermittent issue in software I have no Idea what could be causing that, well except for maybe a hard drive or memory module failure, but lets hope not.

hi guys, just to say all is fixed and my netrunner is working perfect with any funny goings ons now
last time i installed offline and updated later.

this time i did a reinstall to see if it would fix the problem
i redownloaded the iso and burnt a new live usb, and reinstalled whilst plugged into the net.
i then ran update & upgrade
then i used muon cos it had a few more updates supposedly

now on this install everything is working perfectly.
Fantastic distro loving it