Print key (print screen) not working

Hi there,

There is a problem with Print key(print screen) that not trigger “/usr/bin/ksnapshot” and i need to execute this program manually. I saw the System configuration -> Shortcuts and Gestures and this shortcut is there but not working.

Is the printkey in general detected ? So can you reset the shortcut to the print key ?
Is the terminal command xev giving you an keycode when pressing printkey ?

Did you try to relogin or restart when the error appeared ?

xev result is:

KeyPress event, serial 40, synthetic NO, window 0x1400001,
root 0x251, subw 0x0, time 13154366, (-156,-214), root:(395,91),
state 0x0, keycode 218 (keysym 0xff61, Print), same_screen YES,
XKeysymToKeycode returns keycode: 107

My print key is OK and when i used it combine other keys work fine, but when i used it alone not working. And reboot or relogin not change on it.

Can you look again in the systemsettings and try to set a new custom shortcut which starts ksnapshot.
My guess is when you updated from older Netrunner version to 14.1 with the KDE SC upgrade it might have created another entry for starting the Screenshot app. You need to search it though.

I don’t think that is it, this doesn’t seem to be working under Netrunner Rolling or Manjaro 0.9.0 Plasma 5 either.

I’ll have to look into this one further.

I tested it last night but it doesn’t work despite alert that reassign key and i clicked OK.

I didn’t upgrade from older version i installed netrunner 14.1 from it’s ISO file.

I just noticed that the print sc key is actually being listed in two places under Manjaro Plasma 5:

it’s listed under Global Keyboard Shortcuts -> KDE Component -> khotkeys: PrintScreen > print
And under Custom Shortcuts -> Preset Actions - PrintScreen

I’m going to look at my Netrunner Rolling system next.

I’m using netrunner debian edition not rolling and plasma 4.x not plasma 5.

Yes, I know. I was just pointing out that this is not limited to the Ubuntu version, that’s all.
By doing this test I’m ruling out an upstart, etc. issue as Rolling (Manjaro) uses systemd. :slight_smile:
This also confirms that this is also not just a Netrunner configuration problem but a KDE SC 4.14.x / Plasma 5 issue.

I have many distributions installed across many different systems. I’m testing one by one, that’s all.

Then doesn’t it any solution on KDE without calling manually ksnapshot or using other keys for print screen?

I’m not sure is I understand the question, But if you mean changing the key combination on an existing shortcut or to create a new one, then yes that should work. However, I’m now determined to find out what’s causing this and to fix it.

I rechecked on a freshly installed Netrunner 14.1 .
First of all there is a global shortcut set to use the printscreen key in khotkeys. Though we also ship a custom shortcut under preset actions for the PrintScreen key aswell which should call ksnapshot.

In any case both of them are active by default and they seem to work here.
So I would suggest please take a look at the hidden .xsession-errors file in your home directory. Maybe it has any clue on why it isn’t working for you.

There is nothing relevant to this showing in any of my .xsession-errors files. There are some Klauncher errors in all of them, but these errors are different on all systems tested. I can however confirm that after a fresh installation of netrunner 14.1 that it does indeed work as expected, It’s only after an update that it quits working.

So far I’ve tested this issue using Manjaro Plasma 5, Manjaro 0.8.12 KDE, Netruuner 14.1, Netrunner Rolling, KaOS 2014.12, KaOS kf5 2015.01.25, Kubuntu 14.04, Kubuntu 14.10, Kubuntu Vivid Alpha 2, and OpenSuse 13.2. All have them have this same Issue with any KDE SC version above 4.14.2 and Plasma 5.

I haven’t tried a fresh install of Netrunner Rolling yet as that is my personal laptop (production system) that I used to checked this on. I will now do a fresh install of Netrunner Rolling on one of my test systems to see if it works right out of the box so to speak.

Did you happen to enable the Kubuntu backports PPA?

I didn’t enable Kubuntu backports PPA. Are you saying that if i enable backports PPA and upgrading softwares the problem be solved?

My .xsession-errors file content is:

Script for none started at run_im.
Script for auto started at run_im.
Script for default started at run_im.

I can’t find any relevant error in this file.

Nope, not saying that at all. It was just a question. :slight_smile:

If you read my previous post’s this is not a problem that is limited to Netrunner or even Kubuntu, I tried many different distributions and can’t find what updated package causing the issue to find the issue.

Googling “Kubuntu + error” usually helps to spot solutions for problems, at least if it is a somewhat common problem:
#14 on the last link seems working?

Yes, those are both great work-a-rounds for GUI only users.
I was looking for more of a fix that wouldn’t require remapping the default keycode bindings.

Anyway, on HP system the 107 keycode binding would need to be changed:

xmodmap -e "keycode 107 = Sys_Req"

This keycode can sometimes be different depending on the make and model of the keyboard.
You’ll need to run this command to figure out which keycode default is interfering.

xmodmap -pk | grep Print

However, keep in mind that these default keycode setting are intended to allow print screen functionality from the command line shell, virtual console, dos prompt, etc., changing these will disable that functionality. If your often in a CLI only login and need this functionality I would recommend changing your kwin - kde/plasma-workspace keyboard shortcut setting to use a different key combination.

The second post also says fix released 2014-06-12, but since this is still effecting Netrunner 14, it seems it wasn’t back ported or sent upstream to KDE either.

OK, thanks for your reply. :heart:
Now i’m using insert key instead of Print screen key.
Thank you all,

I came back with xmodmap -e "keycode 107 = Sys_Req" and my print scr key is working fine.:heart::heart::heart:
Thank you.
I love Netrunner and forum members:heart::heart: