Printer Setup

System settings Printer of kde 4.11 unable to correctly set a printer using LPD/LPR protocol.
You enter the uri in the menu ex : lpd://, the process goes on until you setup your printer driver.
Then you get the following message : address bad uri device “lpd://lpd://”
That’s effectively a bad uri which I tried to correct but never succeed.

Work around : I used the web interface of CUPS, and within the menu I enter the same uri lpd://
This time all is OK, the printer works.

I had no problems with netrunner 13.06.

KDE bug ?


[color=#000080]Try installing KDE 4.12

I have not had any problem with my printer machines.

If you have not installed the repository, copy and paste in a terminal:[/color]

[size=medium]sudo add-apt-repository ppa:kubuntu-ppa/backports && sudo apt-get update && sudo apt-get dist-upgrade[/size]

[color=#000080]If you already have installed the repository only then copy and paste into a terminal:[/color]

[size=medium]sudo apt-get update && sudo apt-get dist-upgrade[/size]

Checked with system-config-printer.
Same behaviour

[color=#000080]What exactly is the problem? Because in my machines I tried 4 printers, multifunction HP, 1560 HP, Epson and Lexmar and all acknowledge and work without problem on 32 and 64 bit, even networked Windows are still usable.[/color]

It seams rather clear now for me, that’s neither a KDE or CUPS bug. That’s probably linked to a bad configuration generated by the scripts behind system setting printer of (kde) or system-config-printer (probably the same). Apparently they write the following uri :lpd://lpd://, instead of lpd://

The script generated by the web interface of CUPS is the good one.


This seems to be a perfect candidate to report to upstream KDE directly via their bugtracker.

OK leszek, i’ll try, i need to subscribe, but apparently it is very close to this one :


Bug reported :