problem running synaptic

When I try to run synaptic from the menu nothing happens after entering my password. When I try to run it from the terminal I get this:

[b]:~$ kdesudo synaptic
Fontconfig warning: “/etc/fonts/conf.d/50-user.conf”, line 14: reading configurations from ~/.fonts.conf is deprecated.
kdesudo(7854) KDESu::KDESuPrivate::KCookie::getXCookie: No X authentication info set for display “:0”

No protocol specified

** (synaptic:7860): WARNING **: Could not open X display
No protocol specified

(synaptic:7860): Gtk-WARNING **: cannot open display: :0[/b]

Any ideas? This just started today. Thanks.

Running 13.12 updated today with Muon Package manager which seems to run fine, however, software sources will not open there.

attempt in terminal


  1. sudo apt-get update
  2. sudo apt-get instal --reinstall synaptic[/code]

or attempt in terminal

synaptic without kdesudo

or attempt in terminal

sudo usermod -aG sudo <your username>
fc-cache -f -v 

I tried all three suggestions and nothing is allowing me to use synaptic with root privileges. Running “synaptic” without kdesudo brings up synaptic, but without root privileges, it is quite useless. Thanks for the suggestions, however any others would be welcome. :slight_smile: I can always use Muon for the time being.

Symaptic a program that does not require starting with kdesudo or sudo. The program should request the password in the window that appears on the screen. Does the program requires a root password and what happens after that? Are you in the installation Netrunner defined root and user password?

When I attempt to run synaptic from the command line, without kdesudo or gksudo, I get the program to start and a dialog box telling me that running synaptic without root privileges will mean that any changes cannot be made. When started without kdesudo, the program never asks for a password. When I use kdesudo (as the menu item uses in the kicker menu under the command line field), I still get the error above.

I am not sure what you mean by “Netrunner defined root and user password.” I have installed Netrunner to my hard disk and it is the sole operating system on the computer. I picked a username and password during install. I used Synaptic to update the installation immediately after installing the OS. I used Synaptic again to add a few programs such as HPLIP GUI and some others.

It is not that big a deal since I can use apt-get to keep updated easily and Muon for package searching. it just bugs me that Synaptic does not want to run since I like that program better than Muon.

Is Synaptic running successfully if you execute

sudo xhost +
kdesudo synaptic

Sorry, my mistake. I tried to reproduce it in the terminal when I type #kdesudo synaptic and password (do not see anything that’s normal) program starts normally, when I type #sudo synaptic program starts normally. There is a variant to type #su, enter, password, and then typed it synaptic.There is another variant to type #sux, enter, password, and then typed it synaptic. When I start synaptic from the menu then opens a window where I type my password and the program works.
During installation Netrunner on disk installation process asks for type the root password and then enter the user name and user password.

apt-get install sux
Synaptic is a good program, Muon is unstable

[color=#FF0000]Something is not right, your way out of the terminal is similar in Debian.[/color]
Debian can run GUI programs from the terminal only if it is installed
#sux password >synaptic command or #gksu synapticor #kdesu sunaptic command.
Аttempt to edit the launcher in menu for the program and put /usr/sbin/synaptic
I’m confused, the menu launcher is #kdesudo synaptic, if the launcher was localized only #synaptic launches program.

Debian start synaptic from menu ask root password

Netrunner start synaptic from menu ask user password or the translation is wrong

Check if you´re a member of the admin group with the #kuser command. If not add your username to the admin group.

sudo usermod -aG adm <your username>