Problem with duplicated sources.list entry

Someone could explain me why , sometimes when I try to update the repositories , I get the error message of the duplicates entry??
I already solved the problem changing the official-package-repositories.list file, but why?? I haven’t changed or added any new repos, so I couldn’t explain why…
And another question, why the last version of firefox isn’t avialable int the official Netrunner’s repos???

Do you have duplicate entries in the /etc/apt/sources.list.d files ?
If not maybe its a temporary issue only.

As for Firefox we provide version 43 of the plasma edition in the plasmazilla repository which should be active by default

These are the errors I get on update:

W: Duplicate sources.list entry trusty/main amd64 Packages (/var/lib/apt/lists/ppa.launchpad.net_netrunner-os_frontier-14-packages_ubuntu_dists_trusty_main_binary-amd64_Packages) W: Duplicate sources.list entry trusty/main i386 Packages (/var/lib/apt/lists/ppa.launchpad.net_netrunner-os_frontier-14-packages_ubuntu_dists_trusty_main_binary-i386_Packages)
Solved removing a duplicate line from the official-package-repositories.list file. Now everything seems working fine, the thing I don’t understand is how could it be a duplicate line in that file.

For the latest version of Firefox I added the ubuntu-mozilla-security repos, since I didn’t have the plasmazilla repository.