problem with laptop brightness

I don’t know if it’s just me or if it’s a bug but having successfully installed netrunner 12.12 x64 on my acer aspire laptop it’s now started to do something weird; after about 10 seconds the screen brightness widget appears all by itself and turns down the screen brightness to 60%…i thought at first that it must be me and that i’d somehow caused this to happen by messing with settings but i can’t see anything that i’ve done and i can’t stop it from happening - it’s so annoying! can anyone please help?

this might be an upstream kde bug, since the screenbrightness plasmoid was changed to qml:
https://bugs.kde.org/show_bug.cgi?id=310377

You can submit a confirmation that the bug still exists in 4.9.4, maybe its fixed in 4.9.5 though, then you’d have to wait for kubuntubto backport it.

thanks this is def a kubuntu-based problem as i installed linuxmint 14 kde and the same thing happened with that…i think for the moment i will give kde a miss

It seems that this bug is fixed in KDE 4.9.4 https://bugs.kde.org/show_bug.cgi?id=302160, so just update your system or try Netrunner 12.12.1

I just got my Samsung N102 netbook to work. Brightness worked fine w Live CD. However it’d boot w minimum brghtness setting, hence barely readable.

What worked with me was to edit -as root or sudo- these lines of the file /etc/default/grub :

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
GRUB_CMDLINE_LINUX=""

To be:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pcie_aspm=force acpi_backlight=vendor”
GRUB_CMDLINE_LINUX=“acpi osi=Linux”

Then:

sudo update-grub
… and reboot

Hope this helps someone, though the thread is fairly old.


For my first post, here’s heartfelt gratitude to all the giants and all of FOSS, GNU and whatever…
And the same, specifically to the folks who’s put together this awesome distro, with the awesome new KDE///