Questions on a few problems if you know how to fix

Hi there, I’m very new to Linux and NetRunner so will appreciate plain English to assist with my learning curve.

First, I love NetRunner, and would like to use it to replace the default OS. I used it a few months ago and had installed other systems to see which one I liked the most … NetRunner by a large margin.

I reinstalled NetRunner the other day and installed the software and updates, etc, but there’s a few things I can’t figure out which didn’t happen before. I use a Lenovo X121e laptop (Core i3, 6gb ram) –

My problems are:

  1. When playing a movie (SMPlayer) voices are low and everything else is very loud. How can I balance them? Also happens in VLC Player.

  2. The above problem is exacerbated because the FN key and the volume controls don’t work (they did in a previous installation). What have I done wrong here? I’m either craning to hear or being blasted with sound effects. I can’t get the balance within the programs so think it could be a global option somewhere.

  3. The Fn keys and brightness work but I don’t get the jazzy little on screen bar showing the level. How do I get this OSD back (and the same for volume if I can get it working).

  4. I love the NetRunner theme and have customized most of it, but can’t see the option for the big bar at the bottom (you know, where the icons, time, programs are). It’s currently 100% transparent. I want to adjust this so I can actually see the entire bar, maybe something like 50-75% transparency? It’s a small laptop and difficult to read because of the transparency, but I want to keep it a little transparent :slight_smile:

  5. I don’t have a physical (eg, button) to turn on and off the internet. I had to boot into Windows, turn it on (Fn-F5 I think it was), then boot to NetRunner. It’s fine now, but if/when I remove Windows, where is the “hard” switch as it currently doesn’t work?

I’ve figured out most things and NetRunner’s been the easiest distribution from a newbie point of view to install and customize. Love it. Stumped about the above, though. Any help or tips will be appreciated. Many thanks in hope.

OK, after many a headache I’ve made some progress:

  1. Still happens.
  2. Fn keys working: For some reason a service called KMix wasn’t running - it was something else. I disabled the other service, enabled KMix and set it to default, rebooted and it worked. Still get the weird balancing problem with voices and other noises though.
  3. I get the jazzy brightness meter now KMix is back.
  4. No idea
  5. No idea, worst part, but the program “Jupiter” allows the hard switching on and off but ONLY if it is hard switched ON using Windows. eg, if it’s hard switched OFF in Windows, I can’t use the internet at all - this includes other Linux. A killer reason I can’t 100% switch to Linux yet.

Will keep updating with solutions if I find out more to help others.