Random freezing forcing me to reboot

Hi, I’ve been using Netrunner for quite a while now and recently made the jump from Netrunner Ozymandiaz to Rolling using the 2016.01.xx release.
Now I really love it and KDE 5 is magic, its just that the whole thing freezes for no apparrent reason.
I’ve booted up without issues many times, but sometimes: freeze!
I am able to move my mouse cursor but that all seems useless if nothing responds.
I have on occasion left it for an hour or two… but still no progress.

I have no idea where to start getting logs or anything related to the problem as I don’t know what is causing it.

I will install a diffrent window manager (probably LXDE) and report back if the problem persists.

It’s a gpu freeze. Which graphicscard do you have?
Which driver do you use for it? (see my computer as it gives useful information)

I guess it’s a newer Intel card suffering from the dri3 not enabled by default (see the forum search function as this was covered a few times already if my guess is right)

I’ve got a Nvidia 750 GTX, running on the standard Nvidia drivers I got when I installed Netrunner … But I do see why this would be a problem, silly me.
I’ll update it and report back.
Thanks for the help so far.

Do you mean the free (nouveau) or the non-free (Nvidia proprietary) drivers?
DRI 3 is enabled by default on all Manjaro based systems for the free (open source) drivers (Intel, nvidia and ATI/AMD) since prior to the 2016.01 ISO release.

Please remember to use mhwd when switching between free and non-free divers.

There are also GUI utilities in System Settings for mhwd as well.

Hi sorry for the late reply, I am using the proprietary drivers - more specifically the video-nvidia-340xx package… I’ve tried installing the latest release available on the nvidia website but it is giving me problems I shouldn’t get … and the mhwd tool doesn’t styate that that driver should be used on my GPU… so I’m assuming it’s still too far upstream.
For some reason after tweaking some of the basic settings in the driver the freezing happens a lot less, but it still creeps up.

Wait, I’ve just noticed that I have both the nouveau and the 340xx drivers installed… might that be the problem?

Yes, that would be a problem.
Never install drivers outside of mhwd, Manjaro often holds back drivers and/or Xorg itself for compatibility and stability reasons.
If Manjaro installed the 340 driver, then your GPU is not compatible with the latest 352 driver.
You’ll need to run mhwd again to install the nvidia driver properly and blacklist the nouveau.

Ok, it seems to work! thank you very much for the help, much appreciated.

Hi, sorry to bother again, but how do I place the “[Solved]” in the thread heading?
My head keeps screaming to insert it, yet I don’t know how…

Edit your initial post and change the title of your post and add [Solved] to it :slight_smile: