RDP/VNC on Kubuntu


I’ve had another post on here dealing with beta version/realvnc, I’ve since started over and am using Kubuntu 14.10 with KDE plasma (the gold release).

At this point I’m looking for any solution to remote desktop or VNC from my windows 8.1 to Kubuntu 14.10 with KDE plasma (not version 5, its the KDE 4.1 I believe, whatever comes with final release of 14.10)

any suggestions on an RDP or VNC which will work?
thanks AJ

Krfb is the standard solution when it comes to kde plasma desktop and vncserver. It should come preinstalled.

Yes, I’m trying krfb now, and its not working either. The client side (windows) the screen flickers and doesn’t refresh correctly.

Never had any problems with it before. Maybe you try playing with the compression settings or try another client on windows.

I’ve tried playing with the compression settings on the client (windows side)…no effect. I’ve tried Realvnc and tight vnc on the client side…same error.

I’ve tried all of the below, same results , the client won’t refresh. Mouse works but the client shows an old screen and flickers.


I have installed xrdp but have not been able to connect to it. On the client (windows) side I’ve tried RealVNC and tightVNC

Any suggestions?
Thanks AJ

Thanks this is exactly what I wanted and was completely easy! Awesome!

Have you tried any of these:
chrome remote desktop

Actually I gave up on Kubuntu/plasma 5, and moved to Fedora 20. Real VNC put the blame on KDE 5/Plasma, so I figured going to Fedora 20 / GNOME would fix that. It did ,until 4 days ago, I upgraded to Fedora 21…now I have the same issue…with no KDE involved. Oddly, I have a 2nd Fedora 20 which is KDE5/plasma…no issues. I even upgraded to Fedora 21…no problems.

I want to stay with RealVNC…its what all my other boxes are on. There is no reason this should not work. If anyone knows what this issues is, please let me know.

thanks AJ

Maybe it’s the newer version of RealVNC?

I would look closely at what versions worked and what ones didn’t.

No, The old RealVNC 5.2.1 which was existing, did not work either. (after fedora 20 to 21/GNOME) I uninstalled reinstalled RealVNC 5.2.1…no luck.
I then upgraded RealVNC 5.2.1 to 5.2.2 hoping this would solve the issue. It did not.

I feel like its a setting in GNOME…but, I have no idea what or where it would be.

Thanks AJ

Also, the icons do work…if I go to the Fedora PC…all is well. If on the windows 8.1 PC, viewing into Fedora 21, and click an icon…it does work (mouse arrow will do the small spin and turn back to an arrow)…I just do not see the app open on the view-from win 8.1 PC…if I walk over to the Fedora box, the clicked icon app did open…what’s on the Fedora box, is not refreshed back to the viewing win 8.1 box. If I close RealVNC viewer, go to Fedora box and open say 5 apps, they all appear. If I again login the Windows 8.1 RealVNC view…I do not see the 5 apps, only what that last screen was the last time realVNC view was logged in.

OK then, I wish you the best luck.

I am not sure that this is relevant but I use rdesktop to get my win7 desktop and it works very well.

That’s very relevant, there is also the fork of rdesktop called freeRDP?


and here is a great QT GUI for it called FreeRDP-qt: